View Full Version : (SOLVED) People who get the "AC4BFSP.exe has stopped working OR the "AC4BFMP.exe

09-04-2014, 07:28 AM
Hey guys so when I first bought the game when it was released it worked fine. On my main PC got 60fs on everything maxed :)

However last two days the game doesn't load. Keep getting the AC4BFSP.exe has stopped working message.

Tried verifying the cache, reinstalling the drivers and other software but no luck.

Then tried it on my laptop and other PC and even they don't work. Have a mix of Windows 7 and 8.1 and Nvidia and AMD graphics cards.

But I read on a forum where someone said the game must be installed on your C drive (or where your Windows partition is installed). On all my PCs I install my games on the D drive.

If you have this problem where have you got this game installed? C or D drives? Could this be the reason for the error?

Edit 26/11/2013

Guys good news and bad news. Have found why our games crash. Bad news it's our save files. Yep the save game is causing the crash.

My crash started happening after I was playing for a few days and then the game wouldn't start up at all.

One way to tell if it's the save games causing the problem is to check the sizes. Mine were all 1kb in size after playing for a few hours.

Here is what I did:

1. Fire up Uplay
2. Disable Cloud Syncing from the settings menu
3. Close Uplay
4. Goto where you have installed Uplay (for me it's D:\Games\Ubisoft\Ubisoft Game Launcher)
5. Go into savegames and the next folder and you will see a folder named 437
6. This is your AC4 save game location
7. Back this folder up and delete it
8. Now launch your game
9. Voila it works............well it should do :)

But you have lost your save games. I am going to back up my save games every session from now on. If you link these files to dropbox for example, it will maintain a version history and you can go back to a previous version.
BUT i dont think that there will be any more versions from now on
OTHER SOLUTION FOR THE MULTIPLAYER : Disconnect your controlller