View Full Version : AC4 crashes on start up

08-30-2014, 10:04 PM
So I just bought AC4 on uplay, and when I tried to play the game the screen went black and crashed. I then verified the files on uplay and it fixed some stuff, only to get the game to crash on the "press and key" screen when it says it's logging into uplay. I tried opening a support ticket but the support guy told me that since my hardware isn't supported (GTX 880M) he can't do much for me. This ducking frustrating cause I didn't pay money just for the damn game to crash before I even had a chance to play it!
Can someone please help me? Google gave me many solutions, none of which apply to me or didn't work. Please help!

08-31-2014, 06:18 PM
Hello GTarablus, I am very sorry to hear this!

I can offer more assistance if you can please tell us more details on the computer you are running. What operating system do you have?

If it's easier for you, please include the ticket number, so I can look into your DxDiag there instead. Thanks!