PDA

View Full Version : Collision problems



H3X23
08-19-2014, 12:11 PM
On 360 when you disable the collision sound it still plays. Rather annoying when a rock sounds like a barrel!

H3X23
08-22-2014, 03:06 PM
Any word from a Dev on whether this Is going to be looked in to?
I have deleted the barrels but i have uber ramps that i cant delete that are making my rocks sound like they are made of metal when you come into contact with them. I have the ramps set to invisible with contact response on and collision sound off just as I would have done in Evo....

H3X23
09-08-2014, 04:54 PM
? Major kill joy havent played in a while now

JolanXBL
09-17-2014, 05:58 AM
Does that on Evo as well. Could you add an invisible object with a softer collision sound to your object?

TeriXeri
09-17-2014, 10:52 AM
Some of the cliffs sound like a bouncing skippy ball when you land on it, it's pretty odd.

Also Custom Collisions show a lot of dust/dirt when driving over, compared to other objects, wish there were seperate settings for it to set the material type as far as collision sound/particles the wheels generate when driving on it.

Of course there's the option to use invisible objects instead but I don't know if that costs more complexity/performance.

(PC editor but I figure the same for consoles)

IImayneII
09-17-2014, 11:34 AM
On 360 when you disable the collision sound it still plays. Rather annoying when a rock sounds like a barrel!

You can turn off collision sound of most objects in the advanced physics properties. Don't know if that helps

TeriXeri
09-23-2014, 04:23 PM
You can turn off collision sound of most objects in the advanced physics properties. Don't know if that helps

I tested this turned off bike sounds and it only will play the object collission.

The Collision Sound option doesn't do a thing, so it's definately bugged still.

HOWEVER, it seems to work properly when making the object a glue group, it still plays the bike impact sound (which is tied to the bike itself) but no metal collisions from the objects.

Tested / reproduced it, metal objects especially have distinct sounds. If it's not a glue group, the setting toggle doesn't change anything.


Tested some more (building my track with invis ramps as collisions), glue group needs all object to have the same properties for it to work best (same physics type/visibilty)

Dunno if this is PC only but you can add a glue tool to a single object to make a glue group, it's weird but it seems to work as well (also great for making some cliff pieces with no physics have properties like decoration only)