View Full Version : Can't do missions or start new game on ACII

08-07-2014, 12:37 PM
So I recently bought ACII from steam and I played it all the way to Novella's Secret. When I tried to start the next mission after talking to the Fox, Vulpe, I walked into the circle on the ground that marked where i was supposed to be at and nothing happened. The Circle disappeared but nothing started. So i tried to take a random mission and something similar happened. I would accept the mission and then I wouldn't be able to play it. Then, feeling desperate I tried to make a new game altogether, and when I got into the Animus i got a white screen instead of loading the birth of Ezio cut scene.

My Computer runs ACII perfectly fine, its specs are good and that isn't the problem. The problem is, it seems like i can't start anything that isn't already there in the game, i can still find glyphs and feathers, but I can't do missions.

I tried deleting and re-installing ACII, Then deleting and re-installing Uplay, and then googling solutions and deleting a few save files. Nothing works. How do I get past this?

08-08-2014, 12:45 AM
That's a weird one. It's also a new one on me, I;m afraid, I can only point you in the direction of Support (click my sig), who might know.

Welcome to the forums!