PDA

View Full Version : Assassin's Creed Series Cutscene Lag



JarodswartSA
08-02-2014, 09:53 PM
Hello

I've been playing the Assassin's Creed series for a while now, and in every single game up to AC3 (Apart from a few scenes in Revelations) the cut scenes have been lagging, causing the graphics to be out of sync with the voices. The sound would play, and then the graphics would show the word being lipped a few seconds later. I have a Geforce 210 GPU with a Intel Dual Core E8400 processor. I know that it is quite an old processor, but the actual gameplay very smooth. I don't see why the cut scenes in particular would be acting up.

I've been trying to Google some solutions but I haven't found a way to solve the problem yet.

Does anyone know how to fix this problem?

Thanks

Locopells
08-03-2014, 12:10 AM
Hi, welcome to the forums!

This is related to the age of your hardware, I'm afraid, I had the same thing when I first played - older hardware can usually cope with the gameplay fine, but the audio sync in cutscenes is a different matter...

naumaan
08-03-2014, 05:31 AM
hi .. i have the same problem here ... even i have a standard gpu of intel i7 but still it gives a lag ... i dont know why ... and espacially in AC3 and AC4 .. lag iincrease tremendously ... i hope they will rectify this issue in ACU ... this lag issue happens in only AC ... and not other games .. i dont know why ..

JarodswartSA
08-03-2014, 08:16 AM
Thanks for the quick replies everyone!

I understand if AC3 would have lag, but even AC2? I thought my GPU and CPU would be fine to run such an old game smoothly. I recently got a new SFF PC with a Dell OptiPlex 780 motherboard. I've been looking for GPU upgrades but I can't seem to find any that would fit in my motherboard and that is better than my current GPU. Any tips on that issue?

Thanks again guys!