View Full Version : AC4 falling down after few minutes of playing

06-28-2014, 06:47 PM
Hi everybody,

Need your help please, after few minutes of playing the game will go to black window and than i ll end up in windows... all the time and it is saying the game is not responding... i had similar problem thru Uplay account with Far Cry 3 but now it is this game too... if anybody have any advice what to do, please i am listening, thank u

06-28-2014, 08:37 PM
I too am having this problem. In the part where I have to sneak in to free the SAGE.I've tried it 4 times now and ech with the same result Black screen a Not Responding. An suggestions here? Chief

06-28-2014, 08:47 PM
usually such errors are caused by corrupted game files, try to verify game files from UPlay or steam if you have steam version, make sure to run UPlay/Steam as admin before verifying files.

@ Machac22 (http://forums.ubi.com/member.php/1601382-Machac22) , i got your PM and updated this post, please continue discussion here so others with same problem can try it as well and might fix their issue, however, to verify game files on steam:

1. Go to Library.
2. Right click on the game and select properties.
3. select Local Files tab
4. Press the button "Verify Integrity of Game Cache"

if you bought the game through UPlay:

1. Click on games.
2. Select the game.
3. There is a small arrow next to "Play" or "Play Single Player" button, click on it and select "Verify Game Files".

06-29-2014, 02:08 AM
Did the Verify via Steam and all files came back good. Just as a note, there has been no problems up till now other than the fact that I had to disconnect a couple of USB items that were causing a conflict, i.e. Stop and look up thing. But this has got e stumped Also as a note though it seems to be with this mission, it's not always at the same spot. Though they are in the same area, i.e. in the area near the well & the tower.


Ok .... I snuck in without killing anyone though I triggered a minor alarm. I hid the cooled down and I triggered the sequence. So I'm past Free the Sage. But it seems I was supposed to kill at least 2 in the lower fields and 1 in the upper. Oh well. did nothing to my machine.


06-29-2014, 04:09 PM
Many thanks man i did that thing with files... it showed me that everything is ok and from that time it works without problem :) i have to try it with far cry too once again thanks a lot for help

06-29-2014, 10:27 PM
you're welcome, glad to help, enjoy :)