View Full Version : Can't use Season Pass for Assassin's Creed III

06-17-2014, 08:22 AM
I can't begin to described how P*SSED OFF with Ubisoft I am right now. Let me give you the backstory:

I purchased the AC3 Season Pass from Green Man Gaming over the weekend. I tried to activate the key through UPlay, but it tells me it's invalid (WHY THE F*CK CAN'T YOU ACTIVATE THE SEASON PASS THROUGH UPLAY??!!) . Great. So I Google for it and find that I have to activate it through the game menu. Wonderful. So I need to redownload my copy of AC3 since it's not installed anymore. It took me 3 ATTEMPTS to download the game without the installer corrupting. To give an idea of how long that takes, it's a 15gb download and my maximum speed is 575kilobytes per second. Yeah. That long.

So now that I finally have the game up and running (and patched to the latest version) I find that I can now activate my Season Pass key through the "Extras" menu. The key goees in, no problem. It says restart the game to use it. Fine. I restart the game, go to "Tyranny of George Washington" in the menu and get an error message that the DLC can't be found and to check the game menu. Gee, and I was almost ready to believe that I might finally be ready to play this thing after 3 f-ing days. So I go to the "Additional Content" page of the "Extras" menu to download the DLC. It opens Chrome (again, WHY IS THIS NOT A FUNCTION OF UPLAY FOR F*CKS SAKE?) takes me to the Abstergo Store page and asks me to login. OK, I put in my email and password and press login. Then it goes into a f*cking loop loading the page over and over (with the little spinning icon in the middle). I leave it for a couple of minutes and guess what, it keeps refreshing over and over. So I can't access the Abstergo store to download the DLC.


06-17-2014, 09:41 AM
Under the DLC tab on ACIII's UPlay section, there should be listed the three parts of TOKW, and the download links.

06-17-2014, 10:06 AM
Thanks, but unfortunately that doesn't help me. The DLC packs are listed there with the button "Buy Now". If I click them it takes me to the Uplay store (not the actual page of the DLC... just the store.) If I search for the DLC and open the page it's asking to me "Add to Cart" and purchase them. Not really what I'm looking for when I've ALREADY paid for them.

06-17-2014, 12:56 PM
I was afraid of that - they changed the way they did those links during the release, and the links haven't always worked...

I would go to support (click my sig) and tell them your problem - they'll be able to see that you haven't downloaded the DLC yet, and should be able to give you a direct link.

06-19-2014, 03:09 AM
Well it's been nearly 2 full days now since I submitted my ticket to Ubisoft support with absolutely no response. How long does this process normally take?

06-19-2014, 09:00 AM
They're supposed to get back to you within two business days - keep bugging them, if they don't.