View Full Version : Assassin's Creed: Revelations Achievement Problem

06-01-2014, 01:46 AM
I have posted another forum similar to this one with no straight answer on how to fix this problem. The achievements keep resetting on my uplay account. I have the 40 spool file backed up already. This is supposedly the achievement file. 38-45 achievements completed. After I finish the lost archive achievements, the achievements reset to 12-45 achievements completed. The achievements remain recorded in-game, but not in the uplay client. Then, I noticed something, I tried booting the uplay client while in-game (shift-F2). I noticed that the 12 achievements were unlocked on the date December 31, 1969. I'm positive this is a problem on ubisofts end. I tried contacting support, but they were no help at all. Any ideas to fix this?

06-01-2014, 11:29 AM
I've had similar problems myself. Support were unable to help then, either, and I couldn't find a solution anywhere else - I think we're stuck with it...