PDA

View Full Version : Game keeps crashing when pressing "New Game"



Repente
05-26-2014, 07:47 PM
what shall i do? already asked the support; tried all the support's adivces but still doesnt work.. i mean i payed 60 bucks for a not working game?

YazX_
05-26-2014, 08:00 PM
start by posting your system specs and what things you have tried.

Kabor19
05-26-2014, 08:02 PM
install drivers (clean install ) try to swich off firewall and antivirus and check game files from uplay then lunch game.

Repente
05-26-2014, 08:08 PM
Which drivers? got the newest nvidia from today.

MB: AS Rock Z77 Pro4
RAM: 1x8GB Corsair Vengeance 1666MHz
CPU: Intel Xeon E3-1230v2
GPU: nVidia EVGA GTX 660 Ti
SSD: Plextor M5 Pro

support told me a few things, e.g. not using a roccat mouse because they might cause problems (?!?!?!). didnt work.
internet connection through LAN. didnt work
no background services, deleting temp data, deactivating antivir/firewall
tried everything, none did work

Kabor19
05-26-2014, 08:11 PM
http://www.nvidia.com/Download/index.aspx?lang=en-us
or this. its for gtx 660ti : http://www.nvidia.com/download/driverResults.aspx/75991/en-us

Repente
05-26-2014, 08:13 PM
http://www.nvidia.com/Download/index.aspx?lang=en-us
or this. its for gtx 660ti : http://www.nvidia.com/download/driverResults.aspx/75991/en-us

have the newest one, yes

Kabor19
05-26-2014, 08:35 PM
did you check game files from uplay account ?

Repente
05-26-2014, 08:56 PM
yea it tells me that many files are corrupted. then i repair them and when i check again it tells me the same again..

YazX_
05-26-2014, 10:13 PM
yea it tells me that many files are corrupted. then i repair them and when i check again it tells me the same again..

run UPlay as administrator and try to verify files again, Exclude game folder being scanned by your anti-virus also goes for UPlay process.

JacqueTheReaper
05-26-2014, 11:02 PM
run UPlay as administrator and try to verify files again, Exclude game folder being scanned by your anti-virus also goes for UPlay process.

Got the same problem. Tried that but didnt work.

dalehitchy1
05-26-2014, 11:06 PM
same happened here... verefied some files... and Uplay repaired some. initially was crashing but just tried again and got a BSOD.

i5 processor
AMD 6950 card
8gb Ram