View Full Version : Assassinīs Creed 3 Uplay canīt launch game

05-22-2014, 06:14 PM
Dear support and members,

I have just bought Assassinīs Creed 3 game for PC (Czech subtitles) and have trouble with launching. After successuful installation (with patches) and acitavation I canīt start game. If I click on launch button on Uplay, nothing is working. No errors, but game doesnīt start. Nothing working. I tried reinstall Uplay and no changes.
What can I do? How to troubleshot this problem? :(

Thanks for help, very much.

05-22-2014, 08:57 PM
hi and welcome to the forums, there are several reasons on why the game doesnt start, you can try the following simple things, if none worked, we can try other things:

1. Make sure your graphics drivers are up to date.
2. Disable your Anti-Virus or add AC process to exception list.
3. Run UPlay as admin.
4. Set Game exe to run as admin.
5. Launch the game from main exe while UPlay is opened instead of pressing "Play SinglePlayer" from UPlay.

05-22-2014, 09:20 PM
Thank you, I will try it. I downloaded crack from the internet and itīs working now, but I wanted how works game on my computer. I will reinstall game and try your tips.

Thank you very much :)

05-22-2014, 11:07 PM
those cracks are risky and can harm your PC and infect them with trojans, malwares and viruses. and also note that anything related to piracy EVEN IF you own the game will get your account banned, so its better not use it and stick with the official game executable.

05-23-2014, 04:51 PM
Ok, I understood. I have original bought game. After reinstall game all is running awesome, now. However, I donīt want what was the problem. In fact, I turned off my antivirus software to game mode (ESET Smart Security) before launch game. The game is launching successfully now.

Thank for help, very much :)

05-23-2014, 06:51 PM
np, enjoy :)