View Full Version : Crash on start bug fix that is working for me

05-20-2014, 01:32 PM
I was having the same problems as a lot of other players with AC4BFSP not launching at all. I had tried all the bug fixes, game and UPlay reinstalls, driver updates, etc. and still no luck. I had tried the launching game as administrator after a fresh install of everything including moving UPlay and AC4 to my Media Harddrive and managed to get the game to run.....once. Yesterday after tearing through all the bug fixes one last time I noticed something when I launched the game after the 4th or 5th time reinstalling, when I launch the game as administrator it starts the UPlay interface but instead of launching the game from UPlay I attempted to launch it directly from the install directory again WITHOUT using UPlay at all and the game launches. There seems to be something running foul when UPlay updates the the DirectX, Direct3D and .net framework files after installation and if you run the game by launching the .exe directly it bypasses that step in the update.
BTW I am running the game in windows 8.1. Good Luck to anyone still having problems, hope this helps a few ppl.

05-20-2014, 02:46 PM
Thanks for sharing.