View Full Version : Assassin's Creed 4: Black Flag: Screen freezes when I come near forts

05-13-2014, 08:55 PM
I have been playing AC4 since it was released and I never had this problem. Yesterday I played it again, there was however an auto update that was downloaded. After the update downloaded, I started playing. As soon as I load the game, the screen froze, but not completely. Edward and all the other people didn't move. If I moved my mouse the icon for a fort would move and my minimap would rotate. (The game loaded at a fort, that was my last save)

I fixed it (or so I thought) by fast traveling to Edward's hideout. There everything was normal. Today, I wanted to take over another fort, when I got close (900+ range) my screen froze again, I could still hear everything (the ship, fort cannons etc...). I fast traveled again to Edward's hideout. And tried to take over the fort again. The same ting happened again :mad:. This never happened before, it started happening since the last update.

I verified my game files and they are all there. Is this a bug or what?
And how do I fix it? :confused:

05-14-2014, 02:52 AM
I'm having the exact same problem, was working fine just a few days ago and now all of a sudden it just kind of freezes the main game screen when I get close to a fort, either one I control or a enemy one >.<

05-14-2014, 06:01 PM
Yea this is so bad. I checked just now and the issue is still not resolved. Does anyone have more info on this matter? If it is possible can the moderators please in form the dev team of ac4 about this error please.

05-15-2014, 12:02 PM
same here

05-16-2014, 06:36 AM

update: turn your volumetric fog on it will fix the problem

05-18-2014, 05:12 PM
yeah turning on volumetric fog seems to be the temporary fix. However I now get screen artifacting around the bottom right corner of my screen....

Just what did you do in this update ubi?

05-21-2014, 03:57 PM
Yes!!!! Turning on volumetric fog did fix the problem... This is however a temporary solution... Uplay/AC4 devs, please fix this bug/error. Thanks to the guys that suggested the fog thing.

06-02-2014, 11:37 PM
Yeah I am having exact the same problem. I dont like this foggy things, I want clear graphics. But with this Volumetric Fog enabled the game doesnt run smooth.
But now with this bug I have to turn it on.

Its like the Screen (Image) is freezed, you can move around and here people talking, also the Map is moving. But you cant do anything because you only have one image. Its not lagging its more like the images dont get to the display.

06-14-2014, 06:39 AM
I am having an identical issue. This also happens with Smuggler caves. I have not yet tried the volumetric fog "fix", but it sounds like this should solve the issue for now. I reported this as a bug, but got no response in over a week. This is the first time I've heard of a solution, so I am grateful to those that found it.

06-15-2014, 11:05 PM
Yep I just started having this problem as well. What ever was in the last update screwed the graphics up. I try the work around but like others I prefer not to use it if I can help it.

06-18-2014, 04:35 PM
I'm having this problem as well. Hopefully Ubisoft will push out a quick patch soon.

07-02-2014, 07:12 PM
I am having the same issue as well. Whenever I get near a fort, it freezes up the screen. I will work fine once I get out of range of the fort. I am on PC via Steam if this helps.

Found a band-aid fix turning Volumetric Fog on fixes the problem.

07-07-2014, 07:33 PM
I also had this same issue for many weeks. I did not realize at first it was only around the forts and caves. I submitted a support ticket to ubi describing the problem and was given all sorts of steps regarding removing items form startup, updating drivers, etc that had nothing to do with the problem. I also noticed this right after the last patch which I had explained in the ticket. Anyway, I eventually found this thread using Google, and the game works great again now after turning on the fog.

Thanks for providing this workaround here.

10-13-2014, 10:29 AM
Just picked the game up recently in the Steam sale, this bug is still a thing. I'm yet to turn volumetric fog back on, because with it on boarding enemy ships chugged down to 17fps on my poor old 560Ti.

Guess I'll just have to turn vol. fog on near forts and smuggler caves.

Dammit Ubisoft, this is why we can't have nice things (actually, watch_dogs is why we can't have nice things, but this isn't helping).

10-20-2014, 03:25 AM
Yeah, same issue here, I'll give the Volumetric Fog workaround a try, if it works, I'll send in another ticket. Hopefully it'll be looked at at some point.....

11-26-2014, 04:21 PM
Thanks for the fix guys. I doubt this will get much attention with all the fires Ubi has to put out in Unity.

11-29-2014, 04:46 PM
I would recommend that everyone having this bug submits a ticket. With the promotion they are doing to gift people free games that pre-ordered the season pass for Unity there will be new players in Black Flag and this issue might get some attention.

01-11-2015, 07:46 AM
Just ran into this problem today. Submitted a support ticket.Haven't heard anything yet. What is it with Ubisoft and their damned fog? Back when I was playing AC Brotherhood I had to hunt down a third party patch to remove fog that was mucking up the top half of the screen.

01-11-2015, 08:52 AM
this should be a combo of volumetric fog being off and FXAA enabled. If you cant play with fog, try to adjust AA to something other than FXAA or off

07-22-2015, 08:44 PM
Got similar problems but the volumetric fog did not fix it. When I come close to any new location most of the screen freezes - the water and some shadow animations are still "moving" but the ship is frozen and couple secs later the game crashes completely - pretty annoying.

No error message or crash report is created - reinstalling did not solve the issue as well.

OS win7 home prem
Asus G73JH-TZ046Vwith Radeon HD5870 (newest available drivers installed)

07-31-2015, 10:18 PM
Have you tried the support thread?

03-29-2016, 11:00 PM
I just got this game a few weeks ago and have been obsessed until I tried to get to the Dry Tortuga fort and all the restricted zones in the ocean. My screen freezes and I can't continue with the story. Please fix this!

03-30-2016, 12:15 AM
Turning Volumetric Fog on usually fixes this problem.

03-30-2016, 08:10 PM
I had this problem about a year ago, after I bought a new graphic card, and the response from support stated that I need to turn off any of the advanced settings. To this day everything works fine. Perhaps this will help.

05-03-2016, 11:10 PM
:nonchalance: people will be sad to know this is still a thing.

09-16-2016, 06:18 AM
talked with 4 different support people and all have tried installing programs that I already have, disabling applications, updating my drivers which are already on the latest update. Trying to get a chat with the support people again and have to go through 60 other people, even though I legit just went through another 83 before the 3rd support member told me to restart my pc after disabling a bunch of applications. 10 hours of fine game play then suddenly approaching a fort with Torres in it causes my game to freak out, this is the 3rd fort I've approached, the previous 2 were fine

12-28-2016, 09:56 AM
what i do is lower everything in the graphics section when i wish to invade any fort and restore the graphics back once the invasion is over..I know this is temporary solution of this bug but can't do anything else.

12-31-2016, 04:13 AM
After some trial and error I've found this problem is likely related to the PhysX changes implemented in patch 1.07.

I play at 3440x1440 so I need to use modified .exe files to achieve the proper 21:9 aspect ratio. I've kept all the back-up AC4BFSP.exe files dating back to patch 1.04 and the problem only exists when using the last patch which is 1.07. While it's not in the patch notes, THIS ARTICLE (http://www.geforce.com/whats-new/articles/assassins-creed-iv-black-flag-game-update-improves-physx-performance) was posted on geforce.com with some details about PhysX changes. Unless there were other undocumented changes made it's a good bet the fault lies there.

12-17-2017, 09:02 PM
games is given away for free and here i am wondering why the **** image gets stuck sometimes at sea...

then i stopped wondering since why my younger cousin always says "bugisoft" hehehehe

12-19-2017, 10:07 PM
It is 2017 and this bug has yet to be fixed (it likely never will be). Instead, they're just going to hand out the game for free and call it good... Eh, I can't complain too much. The game was free after all. Still, I have this problem too. It happens when I get remotely close to any of the three towers. When it happens, I look at the map and turn right the f*ck around. Adiós glitch! It takes about 10 seconds before my screen unfreezes. Every time it freezes up, I worry that it'll be stuck like that, but all is well... I'll turn on that volumetric fog and lower my settings.

Update: It worked! It does work. Now if only players didn't have to do this, it'd be perfect.

01-26-2018, 05:12 AM
I have turned off all the graphic options and lower my resolution, but still the game freezes and eventually crashes when the character is on land.
the issue almost never occurs while on the ship sailing.

07-01-2018, 01:27 PM
Thanks man, just turn on volumetric fog on. :)

01-30-2020, 01:45 AM
I was having this same issue with AC 4 and while turning on volumetric fog does seem to fix the issue for the most part, it seems the real issue is with anti-aliasing. Specifically multi-sample anti-aliasing. I can set it to any other version of AA and this doesn't happen, but as soon as I set it back to MSAA it happens again.