View Full Version : [Solved]Game crash after choosing track

05-03-2014, 08:18 PM
First things first: System Specs
Processor Intel Core i7 3630QM CPU 2.4GHz
64 Bit operating system, x64 based processor

Now the problems:
Installed through steam and uplay, game loads up in both online and offline modes. However, when I attempted to choose a track the game would crash and either come up with "Trials.exe has stopped working" or take me back to uplay with the message "Thank you for playing".
If this cannot be fixed then can you show me how to get game refunded.

05-03-2014, 08:30 PM
Hello FaZeBlade,

What's your graphic card?


05-05-2014, 12:39 PM
Please forgive the lateness of my reply. I've just uninstalled and reinstalled the game as requested. The issue unfortunately persists. Things I've tried so far:

Un-installed and re-installed the game entirely.
Launch the game in uPlay offline mode.
Launch the game without a connected controller.
Launch the game in windowed mode.
Launch the game without any additional monitors plugged in.
Launch the game with reduced sound quality.
Verified that "My documents" is not on a network location.
Verified that my video drivers are up to date.
Removed the read-only state of "Trials Fusion" folder in "My Documents" .

Please let me know if I can be of any more help.

Tried a few more things. Nothing's helped so far. This is frustrating. Does the game dump an error log somewhere?

Launched the game without the Steam overlay.
Launched the game without the uPlay overlay.
Changed audio device.
Launched the game as administrator.

05-05-2014, 01:10 PM
Hi Steelfrogg,

The game doesn't dump any error log somewhere yet, but we'll probably implement that.
The game was dumping some small memory dumps during the beta, we'll have to re-enable it for the live game. That will help to give some support for cases like yours.


05-06-2014, 07:01 PM
Finally managed to get it working by removing two applications that created virtual display adapters, which I assumed was the root cause of the crash: Splashtop Streamer and DisplayLink. I'm not sure which one specifically caused the problem but for the first time since launch I've been able to actually play.

05-06-2014, 07:17 PM
Hi Steelfrogg,

Thanks for the information. That's great to here.
So, for next time, I hope we'll have the crash dump reporter, then we would be able to see it crashes when detecting the display adapters and that would have been a good hint.
I'll see if we can handle that in a better way.

Thank you for the update.

Have a good ride ;-)