View Full Version : Major PC Editor Issues

04-24-2014, 08:11 PM
The Keyboard/Mouse Bug Collection

Easily Reproducible (With GIFs)

Mouse being moved to other parts of the screen when selecting new objects
Major issues with selecting objects

Easily Reproducable

Crash: Doing almost anything in the properties window for the seed building
cannot select a new object without first deselecting current object (see first GIF)
incorrect position/rotation when selecting a new object (e.g. you have to switch to position then back to rotation)
drag-to-adjust sliders continue long after you let go (joystick virtualisation?)
area selector cannot be removed

Single incidence / unreproducable

Did not exit after going through the "save before exit" dialogue. Exit button no longer worked, left stuck in the editor until I alt-F4
All buttons (including keyboard+mouse) stopped responding

Changed from Trials Evo

can no longer double click an object to quickly bring up its properties
transformation gizmos no longer render on top of everything else
missing quicksave shortcut (Ctrl+S)
keys for multiple selection and duplication have been changed, leaving it unintuitive for Evo players
can no longer use TAB to cycle through gizmos
missing scrollwheel navigation in list menus (e.g. track lists)

04-24-2014, 08:57 PM
Thanks for the feedback, we'll definitely look into these issues. We need all of the feedback to improve the mouse and keyboard combination because it wasn't part of the Beta.

04-24-2014, 09:21 PM
Right. I can capture some Gifs to show the most obvious ones

04-24-2014, 09:25 PM
I was gonna make so many Multiplayer Supercross Maps, the biggest issue is there is no setting to do this!! im not happy:(

04-24-2014, 09:50 PM
Added GIFs for a few, will make more as I find the time.

If you're reading this thread, please post any bugs you find and I'll collate them. Please give a reproducible scenario if you can.

04-25-2014, 01:37 AM
- The translation arrows and rotation circles should be drawn over all geometry, and should be clickable at all time.
- The translation arrows and rotation circles are sometimes way too small/thin (when selecting small objects) which makes them hard to use.
- Can't QuickSave anymore (CTRL-S)
- Using Alt now instead of CTRL for duplicating and rotating is counter-intuitive.
- Shift should be used instead of CTRL for selecting multiple objects.
- In the Tracks list, can't use the Mousewheel to scroll up/down nor move the scrollbar on the left which is essential when you have lots of tracks.

I'll add more soon... It pains me to have to use the controller 50% of the time.

04-25-2014, 04:29 AM
I have the same problem with mouse selection, and it's just as bad as it was in the Evo Gold editor. The 360 pad works perfectly for me, though.

04-25-2014, 07:11 AM
- Adding a Area Selector with the mouse/keyboard. It can be moved around. But it cannot be removed? Delete button does nothing. It works if I use the xbox controller, pressing B button while it is selected, makes it disappear.

- Can't use the TAB key to cycle through move, rotate, scale. (Like it was in trials evolution.)

- Missing hotkey for Scale. Please add one, or bring back the TAB functionality. Or do both :)

04-25-2014, 10:30 AM
Purely talking about the mouse/keyboard interface here:

- Mouse selection issues are really annoying right now as it doesn't work well, usually have to click away at the sky or something to reset the cursor, selecting tends to work better with controller but I don't wanna be forced in controller mode due to what seems a bug.

- Also the selection arrows even if they are huge, are sometimes hard to select when working with objects near terrain as they are inside the ground.

- Rotating objects with the mouse sometimes need extra clicks on the menu buttons to switch between move and rotate before showing the rotate circles.

- I used a giant area clear tool near the snow area/ski lifts and it left behind a few pillars/cables even while they are clearly inside the bubble and base world objects is ticked.

Additional notes:

- Some areas of terrain have a miles long really thin straight line running through, as if its a border between terrain blocks, I see this in Road to Ruin as well, as some editor areas, just a little ugly.

04-25-2014, 01:14 PM
Exit button doesn't always seem to work, left stuck in the editor until I alt-F4
I just experienced something like this, but worse. No buttons at all in the editor worked, including keyboard/mouse clicks. Could not move camera or anything else. Background is still animated in the world, so not a full freeze of the game... I had to force close the game with alt-f4. No idea how to repoduce it, it seemed to happen random.

04-25-2014, 01:35 PM
I just experienced something like this, but worse. No buttons at all in the editor worked, including keyboard/mouse clicks. Could not move camera or anything else.

Had the same problem a couple of times, no idea on how to reproduce it tough.

because it wasn't part of the Beta.

These bugs are the reason why it should have been in the Beta. Leaving it out was a dumb descision.

04-25-2014, 01:50 PM
Editor crashes after roughly 10 minutes for me whenever I play, completely freezes my PC (ALT+F4 and CTRL+ALT+DEL do nothing), although the PC was still running as my skype voice chat was working.

Does it seemingly at random, apart from time taken until it crashes is usually around 10 minutes from booting the editor mode.

04-25-2014, 05:25 PM
The mouse doesn't work at all in the layers menu. I can't select anything.
Sometimes the crosshair cursor in the editor will disappear, and I have to alt+tab out of the program to bring it back.
The active layer resets every time I press undo.

04-25-2014, 07:47 PM
-trying to group objects via the mouse interface, often glues them (happened so far with effects cards/event cards/letter objects) , grouping via object properties works fine.

-layers reset on undo (hidden layers become visible, and layer 001 becomes active) (undo also somehow starts motor noise/checkpoint bleep).

-changing cliff edge (rocky enviroment object) from variation 2 to 1, makes variation 1 all black, this is editing after its placed/duplicated.

Will post more when I encounter.

04-25-2014, 10:07 PM
I encountered a hefty bug within the favorites menu:

I created a rather complex function which would let me rotate an object via the right analog stick in set angeles. It is about 20 function cards big with variables, diffrent events (object postioning, set value, on, off, split and delay filter ect.) When i finished it, I saved it to the favorites. Now if i select it in thefavorites menu the game and/or the pc completly freezes. I tried to select it three times now. Problem Nr. 1: The freeze bug itself, Problem Nr. 2 I can't erase the favorite in the editor because it crashes as soon as i put the selection on it.

So i suppose there's somthing wron with the favorite save system concerning function. Further I would like to know how i can delte a favorite manual within the windows explorer.
Please tell me now.


Okay here's what i found out.The favorites are saved within the TrialsFusion/SavedGames folder within that Windows User Documents folder most
Games put their user data. Every favorite has it's own folder which are named "f643e5d8b40d822d198ad94d-0.o" or something like that. Open it and open the file "displayname" with a texteditor. There you will find the name of the favorite which the folder belongs to.
If you happen to create a buggy favorite erease the folder and it should be gone frome the game.

2nd Edit:

I now have rebuild the function and successful saved it to the favorites. The crash does not occur again. I think it might be that the reason could be connected to grouped objects and/or grouped objects that were previously grouped in a diffrent constellation or in diffrent layers. Before the bug occured the first time there was a warning about grouping object from diffrent layers. I rearragned the layers of the objects before saving but there might be a connection to the problem.

04-26-2014, 02:54 PM
- Object and World draw distance reset to 6000m / 2000m / 400m shadows upon restarting game and loading a track, there's a lot of objects in the world so having to set this every time for performance can easily be overlooked by new creators, mostly it can only be noticed via the statistics overlay or settings themself.
- Statistics overlay does not show on test track, not sure if intended, but it would be handy.
-Sometimes cannot exit editor unless you save even when pressing yes on the dialog (had it happen a few times at start of entering editor/new world)
- the group button in mouse interface, in fact doesn't group at all, but glues everything, did some more testing...
- mouse selecting often needs at least 2 or 3 clicks on other objects or a reset in the sky before selecting something else

04-26-2014, 08:05 PM
Ok, I spent a ton of time in the editor yesterday and compiled a big list of stuff that I encountered. This is mostly just the stuff I thought was serious and didn't have a workaround. I'm stopping to post this now because I don't appear to be able to continue my track without crashing the editor all the time :(

Some of this stuff might have solutions that I'm not aware of, so please let me know if there's something I'm just missing.

Hope some of these notes are helpful. I'm having a great time with the new stuff in the editor :)

--Serious Bugs--
CRASH: I go into game mode settings -> set scores -> click the button to choose the data source for a score and instant crash. This is repeatable on my track currently, but I wasn't having a problem with it before.

BUG: If you are in the data source selection menu, such as setting the operand source for an operator, and you accidentally hit F1 instead of escape, the track settings menu comes open. Hit escape to exit that, and you will get the start menu, then escape again to get back to the editor, and now you are stuck in the data source selection. Escape won't get you out of it. You can, thankfully, save your track when this happens because you can reach the start menu.

BUG: I had a bunch of events selected, hit the group button, and the group pivot was placed a mile away and underground.

--Workflow Issues--
Still no keyboard support for typing numbers?

Some objects like checkpoints can be moved entirely underground, and since the transform gizmo isn't drawn over the terrain geometry, you can't get it back.

The scroll wheel doesn't scroll anything. You can use the mouse to drag the scroll bar in the object selection menu, but in the object properties window the scroll bar doesn't work, and you have to hold your mouse near the bottom of the menu to scroll it.

I might be missing this, but did User Action Center get taken out?

When selecting a color, you need to press enter to confirm it, and escape will discard your selection. Every other dialog in the game uses escape to exit the dialog, while saving your selections.

When you select multiple objects, try to group them, but get the "must be on the same layer error" your selection gets cleared and you have to go through and select them all again.

Selecting a group doesn't give you the same settings in the object properties dialog as selecting the objects individually so you have to select them all individually again even if they're already grouped if you want to change all of their colors or something.

Accidentally created a loop of data sources and got an error dialog that was impossible to exit with mouse and keyboard. Had to use the controller.

The 2d vector edit grid interface doesn't work at all with the mouse. Only controller.

--Issues that have already been mentioned that I would like to reiterate--
Mouse selection is still terrible. Frequently it is almost impossible to select an object even though the cursor is over it and the object is highlighted. Hitting A on the controller almost invariable selects it successfully, however.

Another selection problem: you can't ctrl-click to multi-select something if your cursor is too close to one of the transform gizmo's arms, but the transform gizmo gets so huge when you multi-select stuff that it becomes impossible to avoid.

When you select things, move them, then undo, your selection is cleared and you have to go through the frustrating process of selecting them all again.

04-29-2014, 11:31 AM
- Sometimes keyboard buttons remain on screen, and overlap the mouse interface, only way to clear it is press esc (menu) and go back to editor
- Statistics overlay overlaps some of the mouse interface buttons, in edit mode
- Certain lights turn off at edge of screen (might be intended for performance)

04-29-2014, 01:54 PM
Hi guys,

Thank your for reporting, please keep doing, we're looking at it, reproducing on our side, logging bugs and fixing.


05-01-2014, 09:31 AM
Not a major issue but a Suggestion:
Add an option to turn off Editor Music or at least a volume slider for it seperate from the main game.
It's much louder then regular track music, and I still want my track music for dynamic music events.
After a few days of editing sessions it get's really repetitive, and the music in my opinion isn't my taste.

05-02-2014, 12:30 AM
You guys have covered most of the things I could mention but one thing I really don't understand is why you cant type in the values you want to use. This is the pc version, we shouldn't have to use the sliders to change values.

Another specific game crash trigger is if you try to duplicate the main camera. It's nothing that will affect me of course but it still needs a fix.

05-02-2014, 11:10 AM
-If you have an Emitter, place it, and then let's say , move it somewhere else, then immediately test track, it moves back to the first position as if undo is used, if you do another action before testing, it does not.
-Some directonal light objects have higher then 90 angular light (cone) setting when you place them, but if you lower it below 90 you cannot slide it to the original above 90 (some lights have like 135 or so). Have not tested if custom data source values go above 90.
-Environment,Rocky : Boulder and Boulder(alt) have no physics settings, no decoration only, while other rocks in the category do have the option. (glueing them adds physics options however)
-I had a glue group of 5 effects of the same kind and i could not single select some of them, it would instead highlight another one in the group. When i remade the group anew it worked, so this might be a general glue group related bug.
-The screenshot taken when sharing track is much smaller area then shows on TC, it adds like 40% to the right and 30% to the top of the preview picture.
-Stadium lights show as lights in the statistics overlay very far away and even when turned off.
-Bike light shows as light in the overlay even at 0 brightness, no setting to disable completely.

05-03-2014, 03:39 PM
When I try to remove all bikes from "Allowed Bikes" in the Track Settings, I get the message "You need at least one bike for Trials and Supercross tracks." However, I have the game type set to "Skill Game," and my game character set to a custom object, and I still get that message. I want the game to start without the player having to choose a bike.

05-04-2014, 12:58 AM
These two objects have the exact same color and material properties. However, any color that's assigned to the one on the right ends up with a greenish tint. I have no idea what caused this, but the problem goes away when I change the object to a different variation, and then change it back.

05-04-2014, 11:02 AM
When I try to remove all bikes from "Allowed Bikes" in the Track Settings, I get the message "You need at least one bike for Trials and Supercross tracks." However, I have the game type set to "Skill Game," and my game character set to a custom object, and I still get that message. I want the game to start without the player having to choose a bike.

if you only pick 1 bike they don't have to chose either

05-04-2014, 03:50 PM
I noticed the same with colors, the largest cliff piece turns all black when changing variation after its placed/copied, and some objects with blue emission glow like certain building/industrial parts turn to grey-ish.

05-04-2014, 05:30 PM
After reading all editor glitches/bugs i didnt found this one.

When i share a track the medal times are back to standard, very irritating if u make a hard ninja, because u have to cancle and set times and medals back.

Platform: PC

05-06-2014, 01:01 PM
After reading all editor glitches/bugs i didnt found this one.

When i share a track the medal times are back to standard, very irritating if u make a hard ninja, because u have to cancle and set times and medals back.

Platform: PC
This excactly happened with me in Evo Xbox 360 a whuile back ago, I think it can sometimes be reset when saving.

05-09-2014, 12:17 PM
I noticed yesterday at some point in a track I was building, some trees started to show without leafs (especially noticeable for kapok/elm/mangrove trees as they got a lot of them) , I assume there's just a limit of vegetation in a visible area at one time, once I reduced the number in the area, it was fine again.

05-13-2014, 09:52 AM
Had a few crashes (stopped responding) in a row when working with glue groups or more complex physics joints after moving them around/selecting, so there seems to be an error somewhere in the group/glue/selection code.

05-14-2014, 04:49 PM

Just to tell you the 2 bugs (with GIF) from the first post are fixed in the next patch.
We also fixed some crashes related to glue groups (when deleting them) and some crashes related to "seed building". (can't promise it fixes all the occurences you found, but that should improve stability).

Also, the quick save should be working (Ctrl + S), anyone had this problem also?