PDA

View Full Version : I hate uplay so much



irus_void
04-20-2014, 06:41 AM
For some reason uplay screwed my assassin’s creed IV save. All the work I went through to upgrade the jackdaw is gone. I try to start all over but the game can’t connect to ubi servers.
It stays at connecting screen forever. If I skip it my dlc won’t show up.
I try to reinstall uplay. Uplay wants to download AC4 again. Ok. Start the game. Still can’t connect to their servers. Uninstall everything ubi**** related but keep the AC4 folder so I won’t have to download almost 30gb again.
Reboot. Reinstall. Double click the AC4 exe. This starts up uplay. The only option is a “download” button. Ok, maybe it’s like origin. It will recognize the game is already there and just install it. Nope. It creates a folder called uplay_download or something inside the AC4 folder and starts downloading everything again.
What…
I’m so pissed I hit cancel download and then uninstall in the uplay crap client. The whole AC4 folder is now empty. Funny how uplay won’t acknowledge the game is there when I want to play it but will if I want to uninstall it.

I just want to play the game. I shouldn’t have to go through all this hassle to play a game. All the files are there. Just hit the exe and play. But no. This piece of cancer software won’t let me.

The game is already in my pc. How can i play without this wonderful uplay program downloading it all over again?

Locopells
04-20-2014, 11:17 AM
This worked for me. when moving computers.


Hello everybody. I found really easy way to backup AC4 - and I hope it will be working for you as well.

1. Make a backup folder and paste there whole Assassin's Creed IV Black Flag folder from game installation directory (default: C:/Program files (x86)/Ubisoft/Ubisoft Game Launcher/games)

2. Install Uplay, open, log in - and start downloading AC4. When you'll have few MB, close Uplay.

3. Go to game installation directory - you'll see newly created Assassin's Creed IV Black Flag folder - remove it.

4. Now, the most important step - go to C:/Program files (x86)/Ubisoft/Ubisoft Game Launcher/data/273 - you'll see folder "manifest" and file " uplay_install.state" - remove them both.

5. Copy Assassin's Creed IV Black Flag from your backup folder and paste it to game installation directory.

6. Open Uplay again - and you should see "Play" instead of "Download".

And that's it, nothing more. Hope it will help you guys.

irus_void
04-20-2014, 03:11 PM
Well, it worked. Thank you.

But now i'm back to the "logging in to ubisoft server please wait".

And on top of that i have a damaged save.

YazX_
04-20-2014, 05:15 PM
UPlay depends on registry keys for detecting installed games which is wrong and has to change, there have been similar issues like yours on the forum, one simple solution is to open registry keys for AC4 and then UPlay will detect it and verify the files without the need to redownload the whole game.

now for the infinite logging in issue, this could be solved by:

1. Allow UPlay and AC4 processes through windows firewall software and router firewall (disable them if necessary to pinpoint the problem).
2. Run the game as administrator.
3. Forward UPlay and AC4 ports through your router. (Check Ubisoft Support - FAQ section for AC4 connection issues and you will find the ports)