View Full Version : Sequence 08, Memory 02 Bug?

04-18-2014, 05:11 PM
So I have a fully upgraded ship (Yes, that includes a fully upgraded naval ram), and I also destroyed all the legendary ships, so I have that speed booster thing (which I use a lot). And the problem is, I'm stuck at 99% in my main story sequence, and I need that to be 100% to get all the challenges (I really want that Dead Crew cheat).

What's wrong? Well, whenever I ram into the slave ship, it doesn't say that I completed the optional objective. I figured that it was because the ship itself was destroyed upon impact after a single hit with a naval ram, so I restarted it, and this time when I reached the ship, I kept at half sail and hit the front of the ship, the ship didn't get destroyed, but I still didn't get the objective.

So, I did it again. and this time, slowed to half sail and hit the middle. Didn't work.

Tried it again, this time I went to stop sail, (but I was still moving, just slower, since it doesn't stop right away obviously). I hit the ship, did minimal damage, and STILL didn't get the objective.

Then I tried using the chain shots on the sails before ramming it. Didn't work either.

Is there a live support person that I could talk to? I tried contacting them, but I keep getting an email saying that "Oh this isn't our department, try going to the forums or support.ubi.com.... which I got the email from that website... so now I'm here, and I REALLY need this. Any help is appreciated.

04-19-2014, 01:21 AM
When you say speed booster, you mean the charge attack, right? Otherwise, I don't know what to suggest. Would try it again myself, but can't game for some time to come, sorry.

04-19-2014, 01:23 AM
I suggest moving on.