View Full Version : 'Wrong checkpoint reset' bug

03-31-2014, 12:31 AM
When you reset to the previous checkpoint IMMIDEATLY as you touch another checkpoint, it will take you back to the checkpoint before it, but pressing B again, causes the game to warp you to the correct checkpoint. This can be done with two different outcomes, the 1st is more important than the 2nd.

1. Resetting on the 1st checkpoint on a track, to go back to the start. When pressing B, you will reset your time and gain no faults.

2. Resetting on a checkpoint to go back to the previous checkpoint. When pressing B, you will gain one fault.

Now, the reason why the 1st one is so important, is that you can reset to the 1st checkpoint from a time reset, which means, you would skip the part between the starting line and the 1st checkpoint. In doing so, you will gain one fault, but then you'll be able to get 1 fault runs to be many seconds faster than what's possible on a perfect 0 fault run, depending on the distance between start and 1st checkpoint.

After figuring things out, It seems like it's either a 2 or 3 frame window for the bug to work, but that is 2 or 3 frames too many.


In the meantime, this screenshot should tell you a lot... Such improvement!
http://i.imgur.com/C9L64j7l.png (http://imgur.com/C9L64j7)

Also, HEY, I just beat the top time of this by almost 1.5 seconds!
http://i.imgur.com/xpBz8zDl.png (http://imgur.com/xpBz8zD)
http://i.imgur.com/bH0m4EKl.png (http://imgur.com/bH0m4EK)

04-02-2014, 02:34 AM
Since I guess this will be patched, I just thought to mess around with it a bit, to see how many tracks I could get the best time on. Seems like on Cliffhanger and Fusion Factory, if you activate the bug and stay at the starting line, the animations that should happen, just don't. So you're stuck over and under the massive doors until you press B, which sends you to the 1st checkpoint, or reset. Unwrap the spoiler to see a bunch of exploited times. And yes, I'm a major showoff. :cool:

Also, you thought you've seen broken replays? Go ahead and watch one of my replays.

http://i.imgur.com/Hrh0HUwl.png (http://imgur.com/Hrh0HUw)http://i.imgur.com/vAHMreol.png (http://imgur.com/vAHMreo)http://i.imgur.com/DNtI4Wxl.png (http://imgur.com/DNtI4Wx)http://i.imgur.com/6bHbdROl.png (http://imgur.com/6bHbdRO)http://i.imgur.com/EoLPeonl.png (http://imgur.com/EoLPeon)http://i.imgur.com/awdBEqql.png (http://imgur.com/awdBEqq)http://i.imgur.com/j1r9j64l.png (http://imgur.com/j1r9j64)http://i.imgur.com/kBG8dpFl.png (http://imgur.com/kBG8dpF)

04-02-2014, 11:16 PM
Thanks for the report. We'll look into it.

04-12-2014, 05:08 PM
This got fixed during today's update, but wasn't in the patch notes... I've tried it after each update, but now it's fixed. Tried to do it now and it never worked. Checked footage recorded at 60FPS and found a few frame perfect attempts.

3 frame proof: