PDA

View Full Version : Bug with Connecting to leaderboards... when starting the game 'too quickly'



Zzzlol94
03-27-2014, 12:50 AM
I like pressing buttons, and when it's possible to get to the main menu, i usually mash them a lot. So that's how I found this bug.

If you press Enter, Start, A or whatever button to get through the login screen as fast as possible, about 2-3 seconds before the "Press Enter/Start to Continue" shows up (Also just mashing the buttons until it shows up), you don't get the "Connecting to Ubisoft servers..." screen at startup, also the login takes a set amount of time. The "Press Enter/Start to Continue" is the only thing showing until you're in the main menu. Pressing Enter, Start or A when the bug is activated on the start screen, nothing will happen.

After this, when playing ANY track, the personal best time doesn't exist for some reason, and you won't see the time difference at checkpoints. At the end of the run you will also be told that you've gotten a new personal record and it will be stuck at "Connecting to leaderboards..." indefinitely, until you press B or whatever button used for Cancel. The only way to fix this is to restart the game.


What happens when you press A, Enter or Start as soon as the game allows you to, and this is the screen it will show for a while.
http://i.imgur.com/yUSEOaIl.jpg (http://imgur.com/yUSEOaI)

Two examples of how the bug affects the game.
http://i.imgur.com/ufW7Bg0l.jpg (http://imgur.com/ufW7Bg0)

Here you can see that there are no splits to the personal best.
http://i.imgur.com/jt7N39pl.jpg (http://imgur.com/jt7N39p)

The bug isn't triggered if the appropriate "Connecting" screen pops up.
http://i.imgur.com/ZY9kGr5l.jpg (http://imgur.com/ZY9kGr5)
http://i.imgur.com/cpxBZrAl.jpg (http://imgur.com/cpxBZrA)

Zzzlol94
03-28-2014, 06:32 PM
Seems like this got fixed in the 0.9.1 patch.

Xhane
04-03-2014, 11:20 PM
Great! Please let us know if you see any issue about the leaderboards popping up again!