View Full Version : Diving Bell Glitch

03-21-2014, 05:34 PM
I'm playing the diving bell missions right now but I'm afraid to go to the underwater smuggler dens. Supposedly, there's a bug that makes your hidden blades and blowpipe disappear after you complete the mission and return to the Jackdaw. I've heard no reports of this bug for a long time though. Has Ubisoft fixed this bug already? :confused:

03-21-2014, 08:02 PM
either ways you have to do that mission to progress in the game, i have never encountered this bug, so best thing is to backup your saves, try the mission, if things went wrong, restore your saves.

03-21-2014, 08:39 PM
I have done the story mission that requires diving. I mean those smuggler dens (Anotto Bay, San Juan etc...) You return directly to The Jackdaw instead of the diving bell in these missions. The bug is known to happen in these missions, especially in Anotto Bay. These places are not relevant to the main story. Oh well guess I'll have to stay away from Anotto Bay just to be sure.

03-22-2014, 04:34 PM
Can anybody confirm if this issue has been fixed in a patch? One guy on Youtube claimed that a patch fixed it for him but he was playing it on a console.

03-22-2014, 04:49 PM
I don't now anything about the issue you mention.

I know I completed the game, on PC, did the diving bell, and never had any issue like the one you mention ... or any issue at all for that matter.

03-22-2014, 05:06 PM
For all those who do not know about the issue, here's an old thread that explains it in greater detail http://forums.ubi.com/showthread.php/804951-Game-Breaking-Bug!-I-can-t-use-hidden-blades-and-blowpipe-anymore?highlight=diving+bell.

03-22-2014, 07:17 PM
I did all the diving bell missions ... even the smuggler's lair ... twice on some since I had to go back for assassination contracts.

I played the game this February, and did not have any issues.

I did the swan dive out of the caves, and then climbed aboard the Jackdaw. However, I may not have grabbed the wheel. I may have just gone to the fast travel menu.

I don't think I am going to go try grabbing the wheel to find out. :p I was kinda done with having to swim to the lairs anyways.

03-23-2014, 12:10 AM
Yeah i haven't had any issues with the diving bell either. :cool:

03-23-2014, 12:47 PM
I decided to conquer my fear and give a try. I backed up my save to an usb flash drive just in case before trying. I played one of the underwater smuggler dens and I didn't encounter the bug. However, I didn't grab the wheel immediately when I returned to the Jackdaw, because that is what usually causes the bug to happen. I went to the captains cabin before grabbing the wheel. And it worked fine :).