View Full Version : Fixing the REPLAY GLITCH, one method, input appreciated

06-17-2012, 01:35 PM
Hi http://forum.redlynx.com/forum/images/smilies/icon/biggrin.gif, does your track contain the replay glitch or do you know of a track that does?

If you want to correct a faulty replay try this, its worked 100% for me:(it does mean posting a new faster time, this is so you have a new replay uploaded over the old faulty one)

try this and it should create a fixed replay:-
load the track and play to the end without doing the following:

1: hitting the B button before crossing the 1st check point , i.e. don't restart the track.
2: hitting the back button, even when you've crossed the finish line, again don't restart the track.
3: hitting the X button when you've crossed the finish line, just exit and then watch your replay http://forum.redlynx.com/forum/images/smilies/icon/biggrin.gif

i know what i'm asking may be tough to achieve as you may have to post a top-notch time in one hit.

this to me shows there is a subtle difference somewhere when loading and restarting.

please comment if you try method and its created a new working replay or if you know any other solution that may help, or if you post your glitch replay track name and GT (if required) i'll give it a go, if its not a difficult track (ive not much skill http://forum.redlynx.com/forum/images/smilies/icon_redface.gif )

tested so far:

"monsteur" by "SwAt z DeStRoY", it has the glitch and watched the replay when i crossed the line and it was buggy, i then reloaded track and completed it again and this time i exited and watched the replay which was fine http://forum.redlynx.com/forum/images/smilies/icon/biggrin.gif

tested go ape! by "the emcee" and the replay is fine doing the above, all times i didn't it was buggy, currently at position 70 in the list.

my track abandoned site, the above worked.

thank you http://forum.redlynx.com/forum/images/smilies/icon/biggrin.gif

edit: changed the lay out and tried to make thread sound less obnoxious.

06-17-2012, 01:42 PM
ill try the technique.

i do however see no pattern in the glitches. a run could be glitched when i try to watch it, but at the same time other people could see it working. and it could work for me when trying to watch the same replay later.

06-18-2012, 09:41 AM
I'll keep my eye out for any tracks that have it, but in the meantime I wanted to say something. I've rarely had a replay mess up for me on any TC track the first time I watch it, but with out fail it'll mess up if I watch it again, as long as I exit out of the replay and back to the leader boards when I press Y to watch it again it'll glitch within the first second of the run. Even after replaying the track or even playing a different track, that replay is messed, never tried an Xbox restart though. I've messed up before trying to watch the top time I'll accidentally exit the replay early, when I try to re-watch it the replay will load up and bike and rider will have completely different colors and parts/clothes, and sometimes it'll even be a different bike, then they wreck instantly after "GO!".

Just wanted to share my experience with broken replays.

06-20-2012, 02:04 PM
On my track 'go ape' every replay is bugged. During testing there were no problems...but when i went to share the track my test run showed an issue with checkpoints that meant if you pressed b to go back it put you somewhere below the driving line..rather than the level i set the cp to.

Before releasing it i tested it in mp with someone and they worked fine...so i released it. The track runs fine on TC and cps are working perfectly....but replays with 0 faults are ALL glitched.

06-20-2012, 02:41 PM
The track runs fine on TC and cps are working perfectly....but replays with 0 faults are ALL glitched.

i'll give it a go,.

edit its in your sig doh

06-20-2012, 06:16 PM
Nice track , that part where the ramp passes through the metal ring was tough lol.

good news, I set a time in one hit with 14 faults with a time of 1:37.043 and the replay was fine, i even tried other tracks after viewing and then viewed some broken replays on yours and when i tried my replay again it was still fine http://forum.redlynx.com/forum/images/smilies/icon/biggrin.gif also a friends replay was fine, I'm guessing one hit as well as their time was 02:13.445 with 21 faults.

i really hope this helps RL narrow down the issue.

06-20-2012, 11:07 PM
well i just posted in the top 100, @70 with no faults and a time of 41.492, the replay works fine http://forum.redlynx.com/forum/images/smilies/icon/biggrin.gif

06-20-2012, 11:29 PM
have to say of all the things they could add/fix/change with the next patch, the replay bug is the most annoying for me (or it seems that way anyway)...
do they have any ideas about what is causing it yet?
are they actively looking into it?
i know there are so many things they will be working on, but this would be great to fix

06-20-2012, 11:52 PM
would be nice to think they are, its been a problem since HD http://forum.redlynx.com/forum/images/smilies/icon/sad.gif

my 2cents on the issue is some garbage is not being cleaned or some insignificant (supposedly) variable isn't being reset, i would dump the memory on loading a track and do the same when restarting the track (b button before 1st checkpoint or back button) and compare the class data/etc, a big task for sure.

06-27-2012, 02:49 PM
just a thought, i have a few terrain mods in my map, do you think that there could be an issue with the LOD if its messing with the detection?, maybe the terrain tessellation gets messed up, or are the detection polygons fixed for what ever LOD is selected, regardless of distance?

07-03-2012, 04:03 PM
after talking to apdenton1 about his file size issues, he was told that objects on the same rotation could save space, so i started to experiment and tried this myself, 1st i saved my track that was shared on TC with a different name, then i move most coded objects on my abandoned site track to one location then save it out with another file name, when i compared the files i found both the new files were identical sizes ~76k which was odd as the original abandoned site file was ~156k so i deleted locally abandoned site and re downloaded from TC but this time it was ~106k HUH! why does my track have 3 different file sizes!! , so this got me thinking what if RedLynx are using compression for the tracks and replays and maybe this is what's creating the replay glitch, it would be annoying to find out that some 3rd party compression software has broken your code.

07-11-2012, 10:19 PM
I have recently completed my first custom track, which includes lots of explosions and physics. having a lot of fun in the process.

After finalising my track, I then competed it as if I wasn't the creator, I then went to try and view other peoples attempts.

For some reason when i try to watch any of the other replays. I get a message saying REPLAY CORRUPTED, unable to play replay.

I then tried to view my replay, what goes all the way through fine.

It seems weird that I can watch my own replay but no-one else's.

Any 1 got any ideas?

Feel free to attempt my track, it's quite difficult lol.

Xbox live name:- CHAMPION2308
Track name:- TRY B4 U DIE

07-12-2012, 12:09 AM
corrupted replays are often the result of a long track, will give your track a go.

07-12-2012, 08:07 AM
Thanks for your comment dasraiser.

My track is quite long. 4 minutes flat out.

My next attempt will be a lot shorter.