PDA

View Full Version : Question [SOLVED]



rlmergeuser
07-11-2011, 12:23 AM
Hi, I bought Trials 2 maybe 1-3 weeks ago and it's pretty good. For the first week it worked fine, but now when I try to start it up it gives me an error message: "Could not open windows fonts." It will work once I close that window, but I'll have to lower the resolution or else it'll start to lag. I also can't play on fullscreen because if I do so, the error message window doesn't pop up and I have to close the program. So I'm asking if it's possible to reinstall Trials to make it work again. And even if I remove it and reinstall, do I have to put the same license code again there, because I've lost the email where that code was and now I can't find it anywhere. So do I have to contact to technical support or does it work by just reinstalling? And if I contact that support, do they give me a new license code?

AnttiKi
07-11-2011, 08:30 AM
Hello,

Yes, it's possible to reinstall the game. You should be able to uninstall & reinstall it without entering your license key as long as you don't delete any of the folders manually.
If you have lost the installation package, you can download the demo version here (which activates to the full version): http://redlynxtrials.com/MediaDownloads.action

We should be able to recover your license key if you give us some of your order details, such as your email address and/or name. Just send an email to trials2-support@redlynx.com and we'll get it sorted.

rlmergeuser
07-11-2011, 02:26 PM
Ok reinstalled it but still the same problem. It still gives me the error message and I can't play on fullscreen. Is there any way to fix it?

rlmergeuser
07-12-2011, 01:19 PM
Hi JesC,

your problem could be caused by a few things, but lets start with the one that's easier to fix:
try running the game with administrator -privileges by right clicking the game icon and clicking Run as administrator.

If that didn't do the trick and the error persists, it is time to dig deeper!

Open up the registry editor by pressing WINDOWS-key and R simultaneously and writing regedit in to the Run -window that just opened up.
Now press enter to run regedit, and follow this path from the main folder tree:

[code:5y9591xo]HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Explorer -> Shell Folders[/code:5y9591xo]
Please see if there's a registry key called "Fonts" with data pointing to your Windows fonts folder (default is C:\Windows\Fonts).
And if you could not find the folder or the registry key from the path above, please try checking the path under Windows NT:

[code:5y9591xo]HKEY_CURRENT_USER -> Software -> Microsoft -> Windows NT -> CurrentVersion -> Explorer -> Shell Folders[/code:5y9591xo]

Incase you couldn't find the key in neither one of these locations, then something has most likely removed it from the registry.
This can cause Trials 2, among many other programs, to misbehave. If this is the case then please specify the location of your Fonts -folder incase it's not the default one in drive C, and I will be happy to create a fixing registry key for you!

(While waiting for further help, you will be able to play the game fullscreen despite the error by going out of the game window with ALT and TAB, clicking "Ok" on the error -message and then ALT TABbing back in to the game. http://forum.redlynx.com/forum/images/smilies/icon_e_wink.gif )

rlmergeuser
07-12-2011, 09:24 PM
Ok so I navigated here: HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Explorer -> Shell Folders, and found those Fonts. They are there but is it possible to change it to C:\Windows\Fonts or does it just make things worse? It says there: Data: %SystemRoot%\Fonts. So can I change it manually?

EDIT: I tried your ALT + TAB advice and it worked, but the replays are screwed. When I'm looking those replays on window mode, they work as they should, but on on fullscreen they just somehow go wrong and they're completely messed up. What the hell is wrong?

rlmergeuser
07-13-2011, 07:09 AM
Allright, have you already checked where the Fonts -folder is located at? By default it should be at C:\Windows\Fonts
As for %SystemRoot%, it's a common environment variable which should automatically point to the correct System -folder location.

Let's try forcing the Fonts -folders location in the registry by specifying the path manually, just like you already suggested.
So go back to the Fonts -regkey and change the data by rightclicking the key and selecting Modify... . Type in the exact path of your Fonts -folder to something like shown above, and then try starting the game again.

rlmergeuser
07-13-2011, 01:26 PM
Yay works again. Thanks for the help buddy! http://forum.redlynx.com/forum/images/smilies/icon_e_smile.gif