PDA

View Full Version : Nothing useful happens when clicking any ghost icon [SOLVED]



Flugan
06-05-2008, 01:45 PM
I apoligize if this is the wrong forum but as other people seems to have working ghosts I guess the problem could be rare.

After clicking the ghost button simulating ghost appears for about 1 second before disappearing and then I see the rider past the goal line spinning his wheel but stationary. I can click pause replay and get back to the menu, press R to see the selected replay from the begining but clearly not something remotely near a ghost mode.

If I select pause replay and then select play track from the menu I just get standard play.

I might be expecting something different from what's impemented but it doesn't seem a bit right.

Using steam version on vista 32-bit standard user acount, q6600, 2gb, realtek hd audio, P35 chipset, 8800 gts with everything turned on using normal graphics 1920x1200, (didn't the demo have an extreme mode? might just have been renamed though)

Flugan
06-05-2008, 07:43 PM
I have narrowed it down. It works when I am using an administrator account but not with my normal limited user account.

Used process monitor to narrow down the problem further:
the following file is written:
c:\Users\J?lmbrant\AppData\Local\Redlynx\Trials 2 SE\2.0\ghost.rec
but when it's later trying to read it it seems like the following path is used instead pointing to a probable UTF-8 or similar problem:
C:\Users\Jälmbrant\AppData\Local\Redlynx\Trials 2 SE\2.0\ghost.rec

Because of this there is probably nothing wrong with using a limited account just with using non-ascii characters in usernames.

My admin account is c:\Users\Ulf by comparison.

rlmergeuser
06-06-2008, 02:53 AM
I'm having the exact same problem.

Steam version.
Windows XP.

But, i'm on an admin user and it's "Tin" so i would say that would be a problem in my case...

Anybody has an idea ? i don't, i repeat, i don't have this problem in the demo

rlmergeuser
06-06-2008, 09:03 PM
well i just tried re-downloading/installing the whole game, but i still have this problem...i want to use ghosts http://forum.redlynx.com/forum/images/smilies/icon_sad.gif!

Flugan
06-08-2008, 11:15 AM
This is my results when using first my standard user J?lmbrant and then my admin account Ulf.

This is the point of failure as seen with process monitor which is downloadable from the sysinternals part of microsofts site.

http://img151.imageshack.us/img151/5323/73103597zr5.th.png (http://img151.imageshack.us/my.php?image=73103597zr5.png)

rlmergeuser
06-09-2008, 09:06 AM
Thanks for taking time to analyze the problem.

It is indeed a problem with non-ASCII characters in the file path. This will be corrected in the next version. The release date of the next version is not yet scheduled.

Until that the workaround is to use Windows user name with only ASCII characters.

rlmergeuser
06-09-2008, 02:51 PM
Well, taking that into account (before I read your post) I checked the folder where this should be..

It's not only with Usernames, it's completely with the non-ascii characters.

my folder route is :

C:\Documents and Settings\Tin\Configuraci?n local\Datos de programa\Redlynx\Trials 2 SE

As you can see, I'm using an spanish version of windows xp, so i can't avoid this error.

But, it's nice to hear a response and knowing that this error will be fixed http://forum.redlynx.com/forum/images/smilies/icon_smile.gif

sebastianaalton
06-11-2008, 05:37 PM
We were fixing a lot of directory name special character issues in v1.08, but seems that some of the directory name accesses were not correctly converted to unicode. This problem will be analyzed thoroughly and fixed for v1.09. This is a high priority issue as it also affects the product activation in the non-steam version.

Thanks for all the info provided, it will help us to find the issue.

sebastianaalton
06-19-2008, 01:20 PM
Fixed in v1.08. Release scheduled for next week if everything goes fine in testing.