View Full Version : *Bug Report* Freedom Cry CTD

03-10-2014, 08:10 PM
Sup Forum!

I finally decided to play through Freedom Cry the other day, and honestly I'm really enjoying it thus far, the only problem I have is that when I am doing the mission "Down With The Ship", I will board the ship but upon entering the hatch that is required, my game just shows a black screen with a saving logo for about 4 seconds with the sound of splintering wood and things in the background, but after this my game Crashes-to-Desktop. Now every time I try and load Freedom Cry it just does this.

If you know of anything that could cause this, or know of a way I could stop it, any help would be appreciated :cool:

03-10-2014, 08:41 PM
Try lowering the graphical settings, as well as the resolution. Try different resolutions.

03-10-2014, 11:30 PM
Just tried that and still no luck :( It's a shame because Freedom Cry is such a good DLC

Update: Just tried again and it worked, thank you so much! :D

03-11-2014, 07:13 PM
How buggy is the Freedom Cry DLC overall? I've seen quite a few threads about it's problems.

03-12-2014, 01:59 AM
Is this the standalone Freedom Cry or the Black Flag DLC?

I was interested in getting the standalone just to enhance my collection, but not if this same crappy game-stopping bug is still there. The only way this mission works on the DLC is if you lower the settings all the way down and play the sequence with crappy graphics, which is absurd. It would be pathetic if they never bothered to fix this for the standalone tittle.