View Full Version : AC Rev PC bug 1.02 is the bomb... challenge broken help a fellow rev player!

02-26-2014, 08:51 AM
So im at the end game of ac rev after getting to the 99% marker
but there is a known issue even on these forums and ubi is aware of it but only ACI community helped with one so ill hope you all can find it in your hearts to help

there are 2 bomb challenges that are bugged officially after the 1.02 patch
1. craft a bomb with every shell type
(this I did in the wooden boxes and it never registered, however crafting from the box then opening my inv wheel then crafting more of the same BOMB in my inv NOT at the bomb box let me get this challenge, HOWEVER it did not work for the EFFECT challenge listed below
2. Craft a bomb with every effect
(this is the one I cant complete! I have tried each shell + gunpowder + effect mix that's about 100+ bombs
also I tried going to diff memories earlier in game, nothing, tried the inv wheel, nothing, tried going to the bomb guy piri, making bombs then leaving his house and opening my inv wheel to make bombs in inv, this challenge just wont complete.

ubi and others here say to try to uninstall the game and stop the patching ,but the game auto patches behind the installer on my edition...
and the fix for the 1st challenge that wouldn't complete didn't work for the 2nd listed

and info or helps mates

even ubi said there is no way around the bug meaning ill be stuck at 99% at best )
how did u get to 100%?

again the the only one i cant do is


and trust me i have done this in almost every way i can think of

any info or advice from fellow pc user(s)?

02-26-2014, 04:06 PM
Check the Mediterranean Defense if you have missions for crafting materials. Then you can buy them from Piri.

02-27-2014, 12:18 AM
did you interact with the pictures on the wall at piri place?

02-27-2014, 01:51 AM
as for med defense.. mate im at end game

so all the missions are done, those piri missions were the first thing i did do

as for the pictures on the walls yep .. did that too

also tried like i said to make the bomb in inv wheel (which fixed the shell bug) but not the effect one

ubi says its a known pc 1.02 issue, for sure the patch is what did it not the core game (as my first time playing this long ago upon launch date this problem didnt exist)

any other help or infos?

i even tried every memory to make bombs in , just to see if that worked too

02-27-2014, 05:40 PM
i encountered this bug while trying to unlock this achievement or challenge (i dont remember) but when i interacted with all pictures on piri's wall it worked just fine, and yes i was done with the game, so its the same case as yours.

02-28-2014, 06:45 PM
Why don't you install the 1.03 patch?

03-01-2014, 03:12 PM
yep of course 1.03 patch

it didnt fix the bomb issue, as 1.02 patch miffed it according to ubi reps

got 100% in game only thing i never got was this single challenge done.. shrug

any other tips?
or infos

ty btw! for the replies

hope someone knows how

1. tried the piri board (100% complete)
2. tried making bombs in box, then leaving using inv to make em
3. tried in piri to make em
4. tried EVERY memory to make bombs in, so far nothing..

1.03 PC signature edition with all dlc owned and installed

03-01-2014, 03:34 PM
I really have no idea. The challenge worked for me...
Try making another savegame.

03-01-2014, 11:35 PM
Original Post

I know that feeling, bro...

I had the same problem and solved it by reinstalling the game and NOT installing any patches (by closing the update window that shows up when you start the game). Then craft and throw the bombs, get the achievment and after that you can update to the latest verison.

03-03-2014, 07:54 AM
Its still doable with the latest patch. Game doesnt not count bombs made at a crafting table. But its not the only way you can make bombs.
Make one bomb, leave crafting table, open weapons wheel and make another one (replenish) from here.