View Full Version : Ezio, Connor and Altair costumes have disappeared !

02-01-2014, 09:59 PM
So, here is my story...

When I got black flag and played it for the first time I got the Ezio, connor and Altair costumes for owning atleast 3 other AC titles other than AC4. I tried them out, they showed up in the outfits section for Edward. It was good.

Then my HDD died, so i got a new one, installed windows etc, installed AC4, replaced the save files that i had backed up as uplay cloud does not work for AC4 anymore.
And I cant see these outfits anymore, i dont have them.

I would like to add that i tried installing AC2, ACB, ACR, AC3 and even played around in each of them a bit, because i read somewhere that everytime AC4 launches it checks for save files on the PC for previous AC's and then unlocks the costumes/outfits.

Still after doing that, the outfits in AC4 do not unlock.

Long story short, I had the outfits, HDD died, got new HDD, installed AC4, dont have the outfits anymore, and they dont unlock....

I've submitted a ticket with ubisoft support....but i get a feeling that its not gonna be of much help...

Has anyone else had this problem ? Does anyone know of a fix ?
Please leave suggestions or replies...

Thanks in advance :)

Btw, great job ubisoft !

02-02-2014, 03:45 AM
It has happened to almost everyone else on PC. As far as I know, the teams are aware of it but they haven't done anything yet. There are solutions for consoles, but not PC. =/

02-02-2014, 06:12 PM
Yep this happened to me shortly after launch, I have given up hope, and have only been playing the game during community events.
So I know I'm connected to UPlay if I am getting the awards for the community events, but still no outfits.