View Full Version : Why does it barely run on low though my PC fits the recommended requirements?

01-26-2014, 04:54 PM
I use an AMD radeon 6850 GPU and these are my PC specifications right from dxdiag.. on normal quality fps drops to around 20-25, at low it's 30-40. I'm woundering why is that, cuz my chips seemed to fit with the AC black flag recommended requirements in http://www.game-debate.com/games/index.php?g_id=6805&game=Assassins%20Creed%204%20Black%20Flag

System Information
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_rtm.101119-1850)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: H55M-D2H
BIOS: Award Modular BIOS v6.00PG
Processor: Intel(R) Core(TM) i5 CPU 760 @ 2.80GHz (4 CPUs), ~2.8GHz
Memory: 8192MB RAM
Available OS Memory: 4056MB RAM
Page File: 2293MB used, 5815MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

DxDiag Notes
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

DirectX Debug Levels
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

Display Devices
Card name: Radeon HD 6800 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x6739)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_6739&SUBSYS_21F91458&REV_00
Display Memory: 2784 MB
Dedicated Memory: 1012 MB
Shared Memory: 1771 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: M2380D
Monitor Id: GSM57BA
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: HD15
Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,at icfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64 .dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a. cap,atitmm64.dll
Driver File Version: 8.17.0010.1047 (English)
Driver Version: 8.782.0.0
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 9/29/2010 04:54:02, 628224 bytes

Thanks, and sorry if that's more than needed.

01-26-2014, 07:05 PM
AC:IV is poorly optimized. Like--extremely unoptimized. I recommend you force enable triple buffering and v-sync through D3DOverrider. You should jump about 5-7 fps and keep the game stable.

It makes you wonder if they're actually doing anything when they delay the PC release.

01-27-2014, 03:04 AM
It could be your low memory compared to the requirements.

Memory: 8192MB RAM
Available OS Memory: 4056MB RAM

Minimum Req:
Memory: 2 GB (4 GB recommended)

01-27-2014, 12:28 PM
What settings do you use? You only have 1GB of VRAM so I suggest you set the texture settings to low as normal setting uses over 1GB.

01-27-2014, 01:00 PM
My PC doesn't even meet the low requirements and I can still play the game in low settings (with GodRays) at 40 FPS. And I can play the Multiplayer with 60FPS at low (with Post Effects off).

01-27-2014, 06:24 PM
Your specs look good other than your video card -- I would recommend dialing down your resolution or texture settings a bit. Not much VRAM to work with.

01-27-2014, 07:17 PM
Hey, thx for the replies. so the problem is mostly my GPU?

These are the settings I used to get a range between 30-40 fps


But with keeping the texture at low and rising the shadow reflection and environment quality to normal it stayed pretty much the same


Okay I also have 2 rams each 4gb, but noticed that in task manager it says my physical memory is only 4GB while dx diag seems to recognize the entire 8gb ram.. could it be that my computer is not recognising my second ram?


Anouther annoying problem are the shadows, The shadows look stutter and somewhat shaky, but this occurs in multiple games in my computer not just AC.

(like the shadows in this building)

01-27-2014, 08:29 PM
just a suggestion
change resolution to 1280x720.
I did it.
This and a simple antialias gave me tthe right compromise between performance and graphics quality.
I also followed this suggestion



01-28-2014, 05:36 AM
Well, a lot of folks will keep suggesting that your graphics card is the problem. True, it may be the weak link according to Ubisoft's recommended specs, but I can tell you what the issue also could be: It's may be your CPU. When I say that, I don't mean it's your fault though. I mean, this game is ******** optimized. It's just true...

I keep hearing a lot of crap on forums about ACIV optimization, and people saying, it's not that bad, runs great for me. Just because it runs good for some people, does NOT mean it's well optimized. :)

So, anyway, the truth is, the game is poorly CPU optimized, so for most of us, our CPUs are bottlenecking our GPUs and our framerates.

For me, with a Quad Core CPU, The game runs THE SAME on just 2 cores, as it does on all 4. I can go into task manager, set affinity to 4 threads (2 physical cores), and the performance is crap, around 35FPS. Activate my other 4 threads (an additional 2 physical cores) and nothing. Not one FPS increase.

This is because of how Ubisoft's engine is. It throws 90% of it's load for the game on the first core, the other 10% on the second core, and the last two sit completely idle.

It's really sad, but yeah, that seems to be the problem for most folks. A lot of people are thinking it's their GPU, when in fact it's their CPU. This game is super CPU intensive.

A link with benchmarks to back up what I'm saying: http://www.dsogaming.com/pc-performance-analyses/assassins-creed-iv-black-flag-pc-performance-analysis/

Read that article, as it explains a lot better than I can.

01-28-2014, 09:30 AM
Normal environment quality enables the advanced foliage system and its very GPU intensive. It is also true that the game is not well mulit-threaded. I have reported this issue and it is currently in second level support as I've reproduced it with screenshots and info tech support wanted.

01-28-2014, 11:32 AM
very odd that only half the ram is recognised though..

I would suggest working with support though, since they may have suggestions..