View Full Version : Uplay server unavailable. Please try again later. Still unable to play.

01-04-2014, 06:15 PM
I purchased the PC version of Assassin's Creed III from Target.com last week (12/27/13). It finally got here on 1/2/14. It is the PC version. After I installed the game to my computer, then installed the necessary updates for the game, I was then prompted to create a Uplay account. I did that.

Every time I open ASC III, I can click play, then I am sent to the Registration page. For 3 days now I have tried to enter the Activation Key to register the game. Every time, I am given "Uplay server is currently unavailable. Unable to register the game, Please try again later." Well, I have tried again later. And Again. And Again. Like I said, for 3 days I have tried.

I can't even play in single player or anything. So here I am, with a game I can't play.

I have entered a Technical Support Ticket, but still have yet to receive a reply. And apparently will not get one until next week sometime because they are closed for the weekend. This is the first time I have ever purchased a Ubisoft game. Is this a common occurrence? Is there a way around this issue? I don't want to play in mult-player only single-player.

I just want to play the game that I purchased!! I am tempted to try to return it to Target. There is positively no reason for this kind of hassle.