View Full Version : Assassin's outfits aren't appearing?!

12-29-2013, 11:08 PM
For some strange reason I didn't get my Altair, Ezio, and Connor outfits for AC4. I've played (yes, also redeemed at least 2 things from each game) AC2, Revelations (I deleted my save though), and AC3. I got neither one of the outfits. I have also played up to the part where you gain access to your cabin on the Jackdaw. Am I missing any requirements?

I have internet access, played the games mentioned above all on the same console, and obviously have a Uplay account.

12-30-2013, 04:20 PM
I got the same problem, with no sollution. I have the Altair and Ezio outfits, but am missing the Connor one. I contacted the Support, they asked for a screenshot, which I provided, but that was all. It seems like not only PC gamers have this problem, but also nex-gen consoles (I've read about several cases). Another thing is that Social Events do not appear, I have played the game for 3-4 hours a day for the last week, and nothing.... Hope they fix everything soon (although I doubt it)

12-30-2013, 04:39 PM
Yep, known issue appears irregular on all platforms. I didn't get the outfits since release of the game, the support couldn´t a find solution until now. Hopefully the next patch will fix this annoying bug.

If you find a solution, please let me know! :)

01-08-2014, 10:19 AM
I have downloaded from Steam all the AC Saga (From AC1, to AC Black Flag, including Revelations, Brotherhood and Liberation HD), and according to the info ubisoft gave, If you synchorinze all your games to uplay, as long as you have played at least 3 of them long enough to make uplay recognize 1 achievement, the game will automatically unlock 3 special outfits for the single player campaign (Altair, Ezio an Connor outfits), but in my case, the outfits didn´t unlock at all, no one of them. So i tried to advance more in the game to see if that unlocs them, but nothing happened, then i tried to connect to the other online services (Multiplayer, AC Ininiates, Kenway´s Fleet, etc.) and i did it without any other problem to consider, so i contacted ubisoft support and told them my issue but they just told me that it was a bug, so i found it usseful to report this on this forum too. (By the way i've been reading the formus and according to them, if youre playing on a XBox or a PS, these is a way to solve it, you only need to unlink your account, and link it back, and voila!!! problem solved, but in PC you can´t do this so.. i hope someone read this and really trye to fix this out)

01-08-2014, 06:04 PM

If people are still having issues - please do make sure you contact support, if you have not already!


01-09-2014, 02:30 AM

If people are still having issues - please do make sure you contact support, if you have not already!


Well, as i mentioned before i've allready contacted the ubisoft support, but this are the answers the gave me....

Steven 1/2/2014 12:37:19 PM
These should unlock if you have played previous games on the same account. Having accessed one previous Assassin's Creed game whilst logged into Uplay will give the Altair costume, two will give you Ezio and a third will give you Connor's outfit. Please login to your Uplay account and provide a screenshot showing you have played the previous games on the same Uplay account.

Steven 1/3/2014 9:23:58 AM
Thank you for highlighting this issue to us, we really appreciate you taking the time to report this. We have passed this information on to the appropriate department and as soon as we have a solution it will be posted on the official web-sites. www.ubi.com https://forums.ubi.com If you have any further queries or issues please do not hesitate to contact us again and we will assist you further.

So, as far as i know, today there isn´t a solution for this [Bug / Glitch] in the Character Outfits... too bad!!, but as a good fan, all i can do is wait till the "appropriate department" fix this... hope its soon!!! :D!!