View Full Version : Freedom Cry DLC Plantation CTD

12-21-2013, 05:52 AM
The plantation in the northwest part of Port de Prince causes CTD for me. I can kill anywhere from 3 to 5 enemies, but right about midway into that area - it causes CTD.

Anyone else having such an issue ? I've read about the freeze after memory 1, didn't experience that. I've read about freezing from looting corpses. Didn't get that either. I completed the first few memories, but I'd like to get the forth viewpoint and the remaining chests - can't do it though, I get CTD everytime.

I tried disabling UPlay overlay, nothing changed. I then tried setting UPlay to offline mode - that locked up my PC when trying to load my Freedom Cry save.

What a shame, I really wanted to enjoy what I paid for. I paid $80 for the Gold Edition, and this is really unprofessional of a software company to release such unstable software.

Never did see a 3rd Royal Convoy so I could get the Aquila figurehead. Never found a single social chest. The community challenges were always greyed out. And I only came across 2 white wales. This is spanning across 98 hours of gameplay. Campaign done, Aveline done. I don't do MP.

Really wish they'd have fixed this BEFORE releasing it.

I'll not be pre-ordering any more content for Ubisoft games. I'll just wait till they go half-price. Not worth my money at full pop, not with this kind of quality control. Long time fan of the series, here, and highly disappointed - even though I really do enjoy the series.