PDA

View Full Version : Freedom cry crashes during loading screen after finishing first memory.



bhhari91
12-20-2013, 02:31 AM
As the title says the game just crashes after finishing the first memory, in the loading animus screen.
Has this happened to anybody else ?
Please does someone know how to fix this ?

bhhari91
12-20-2013, 03:22 AM
*bump*
plz can someone help ? :(

Frag_Maniac
12-20-2013, 06:36 AM
Try disabling the UPlay overlay.

Explanation here:
The first time I tried launching AC IV after Freedom Cry downloaded the game wouldn't even launch. There was a "Program not responding" error. So I tried disabling the overlay in UPlay. It then launched fine and it's been playing OK except for one screen freeze in Port Au Prince while I was looting a corpse. I am now about 1/3 through the DLC.

I have launched the game with UPlay in online and offline mode, as well as with Steam in online and offline mode. There's no change either way for both. I also noticed that every time I exit Freedom Cry, instead of exiting to main menu like it says, it exits to the Freedom Cry Launch/Save menu. When hitting Esc, instead of going straight to the main menu, the UPlay desktop appears, then disappears briefly showing my PC desktop, then the AC IV green loading page comes on saying connecting to Ubi servers, then it finally goes to the main menu.

Once I got to 33% completion I tried enabling the UPlay overlay again, and it launched fine, but I wouldn't recommend starting a campaign that way. I would play at least until the 2nd mission without the overlay, and make sure it saves OK first. It would appear Freedom Cry is having a problem connecting to and/or staying connected to Ubi's servers.

bhhari91
12-20-2013, 12:51 PM
I solved my problem by using the 'verify files' feature in uplay for ac4.
It verified my files and then told me to download something, it downloaded 2 files for the dlc10 folder and replaced them, i think.
Maybe those 2 files had been corrupt or something.
After that my didnt crash while going through that loading sequence.
Thanks for your help.
And if anyone else is facing this issue, just try verifying the ac4 installed directory using uplay.

Frag_Maniac
12-20-2013, 02:49 PM
I solved my problem by using the 'verify files' feature in uplay for ac4.

Well I knew you could do that with Steam, but how do you verify files with UPlay?

bhhari91
12-20-2013, 06:40 PM
You go to the game's page in uplay, where it shows achievements, dlcs etc along with the 'Play single player' button.
Attached to that button is a small down arrow icon, click on it and there will be 2 options, verify and uninstall.

Frag_Maniac
12-21-2013, 02:00 AM
You go to the game's page in uplay, where it shows achievements, dlcs etc along with the 'Play single player' button.
Attached to that button is a small down arrow icon, click on it and there will be 2 options, verify and uninstall.

Yeah I had already tried that, doesn't show as an option. My AC IV is a Steam copy, so I didn't expect it to, but my Far Cry 3 is a UPlay copy I got free with my GPU, and that drop down box only shows uninstall as an option. I do recall having a hell of a time with the UPlay downloader wanting to download and install it on my small SSD OS partition though, so maybe changing the install path messed with UPlays detection of the game files. You'd think if it can uninstall it it can verify files though, stupid.

Whoever wrote UPlay did a horrible job. It's largely regarded as THE worst game browser in the industry, and Ubi don't want to admit it.

http://imageshack.com/a/img203/8020/jjeh.jpg