PDA

View Full Version : Freedom Cry not available to Steam Season Pass and Gold Edition owners.



WarlordSpinal
12-19-2013, 12:28 PM
Posting this thread in hopes of attracting an official response.

From what I am to understand, earlier yesterday, Freedom Cry "officially released" according to a twitter post here;

http://puu.sh/5Ryi3.png

The problem seems to be in the fact that Steam forgot to add Freedom Cry to everyone's season pass. There is no database entry for it in the Season Pass' database, as you can see here;

http://steamdb.info/sub/33495/#section_apps

The only people playing Freedom Cry with their Steam version right now are the ones that bought the DLC SEPARATELY without the Season Pass. And even for those people, the DLC is listed as "OWNED" with a check mark in the UPlay launcher. So the problem does seem to be Steam in this case. I'm not pointing fingers. Simply looks like that to me from these drawn conclusions.

I understand people with non-steam Season Passes are also experiencing this problem (I assume UPlay-acquired Season pass?)

I realize there is a discussion of this going on in a thread right on this page. But the title does not indicate an urgent problem. This title does.

As I said, I hope for an official acknowledgement as soon as possible.

medavroog
12-19-2013, 01:05 PM
Why am I ... NOT EVEN ... Suprised at this out-come?

NoisyCosmos
12-19-2013, 06:35 PM
I've got the same problem like many many other users that own the season pass. Please UBI fix that.

YayaTourette
12-19-2013, 06:48 PM
It's not just Steam customers. Also Uplay/Ubishop buyers of the Digital Deluxe Edition + Season Pass are affected, too.

Frag_Maniac
12-20-2013, 12:00 AM
Steam forgot to add? You do realize Steam is just a game browser made by Valve, and is programmed, not cognizant?

It's already been proven here yesterday that Season Passes on Uplay weren't even showing the Freedom Cry DLC in it's list of contents.

It all starts with Ubi, it's their product and gets distributed to Valve in the state Ubi leaves it in, it's not Valve's fault.

As soon as I opened up Steam today it started updating Black Flag with what appears to be a file that will take the better part of an hour to download. It's currently at just over 3/4 completion and the game's properties now shows Freedom Cry as part of the DLC, even though the file hasn't even finished downloading let alone installing. If you ask me, Valve are lightning quick at correcting other's mistakes once they can.

http://imageshack.com/a/img51/6574/bw6d.jpg

Mr_Shade
12-20-2013, 11:26 AM
Hi Guys,

Steam users should now have access to the DLC - please reboot /restart if it's not showing.


If you are not a Steam user - please bear with the team while they work to correct this!

medavroog
12-20-2013, 11:55 AM
... If you are not a Steam user - please bear with the team while they work to correct this!

I am trying to bear as I write these words and, form my posts over these 24hrs and beyond ... I am basically deep in anger for obvious reasons. However, I will allow myself to trust UbiSoft again ... please please please, don't disappoint; thank you for informing us, and I thank the team before hand ... please, don't let me down.

UnsungPatriot
12-22-2013, 12:26 AM
Greetings Mr_Shade,

I am a Steam user and I did reboot/restart as instructed as well as verify the cache of the game in Steam. Everything was officially validated. I am a Gold Edition user as well. I checked the DLC tab in my steam library same as Frag_Maniac above has done and it reads exactly the same as his image. Also, in the Uplay menu it does show that I have Freedom Cry in the DLC sub-window there. Freedom Cry is still not showing up on the main menu of the game unfortunately. If there is any other information you may require to help just let me know. I am using the latest beta version of Steam and the Black Flag version is 1.04. I wasn't sure which information would be relevant to you in this instance to send up the chain.

P.S. Just checked now at the product page for Freedom Cry DLC on steam. It doesn't seem to show that I am the owner of the DLC as it normally does for content you own, yet it's listed in my library when I right click on Black Flag > Properties > DLC tab.


------------------------------------------------
(UPDATE: SOLVED)
I fixed my issue. It's always the simplest solution. I right clicked on Black Flag in my library and saw 2 CD Key codes there. I didn't remember submitting a code for a season pass, only the game when it initially came out for PC. Activated the season pass and voila issue solved and Freedom Cry is there now.

esckobar
12-22-2013, 12:44 AM
Hi there.

I'm having the same problem. Freedom Cry DLC nowhere to be found.

I have the Deluxe Edition from Steam, with the Season Pass bought.

Please sort this out!

Frag_Maniac
12-22-2013, 01:54 AM
Freedom Cry is still not showing up on the main menu of the game unfortunately.

Did you check the Aveline tab in the upper right corner? that's where it should be.

m3inity
12-28-2013, 01:14 PM
I have the Gold edition on Uplay directly, not Steam, and none of the SP content is showing for me.

Faded24_7
01-01-2014, 06:27 AM
I got the game threw Origin and i Also have nothing :( lol paid 84 bucks to play the normal game :(

Frag_Maniac
01-01-2014, 10:11 AM
This thread if nothing else is proving to be great advertising for Steam. LOL

Mr_Shade
01-01-2014, 05:40 PM
Hi Guys,

If you are still having issues getting the DLC - please do not hesitate to contact support directly, they are the guys you need to be working with.


www.support.ubi.com