View Full Version : Patch 1.03 broke my multiplayer

12-11-2013, 10:30 PM
First of all, hiya, been a while ;)

Second, the patch broke my game as well. Yet, I have no issues with the not booting part, but with the simple fact that yesterday multiplayer was working fine. Played tons of games, had tons of fun, really appreciated all the effort Ubi put in to make the multiplayer work as it should (compared to all previous versions of the multiplayer that were riddled with issues and bugs). But, sadly, today I was forced to download a huge update that would improve connection issues that I didn't have, yet... Now, I can't seem to connect at all any more :S I get invited, disconnected. I queue for a quick match, disconnected. I even had to remove all port forwarders etc. to get my orange NAT back! What? Yes, indeed, I had orange NAT after setting up all port forwarders and exceptions etc. that made me feel really proud about myself for getting the game to work in the first place, now they messed up the game so I had to remove them again, yet I'm not able to connect anymore (removing the exceptions and port forwarders etc. got me from red NAT back to orange, but without being able to connect... huh?)

So, to sum up:
- yesterday game was working fine, near perfect even
- today patch downloaded, and NAT changed
- after getting my orange NAT back, I keep getting disconnected at the start of a session (the game actually says "Session is about to start" and then 'You have been disconnected from host', once in a while I actually get to select an ability set before getting kicked...)

Wondering if there's anyone else with these issues out there, or someone with more experience with this game than me, because I've given up hope and support isn't helping...

12-12-2013, 01:19 AM
I know this won't help with your immediate problem, but whenever my NAT was "orange", I had all of those issues as well. Only when I have "green" NAT does my game work normally.

12-12-2013, 09:31 AM
Well, orange worked fine for me on Tuesday, just got messed up after the patch yesterday.
Green NAT is impossible for me to get, because of this stupid router/modem I got from my ISP... There're plenty of games that just won't go green on this router, but none that won't work at all, except for ACIV 1.03 :S

12-12-2013, 02:55 PM

I have a green NAT and yet I'm having the exact same issue as you are.

12-12-2013, 04:15 PM
Try to run the game in administrator mode and/or run the file pbsvc (Punkbuster), which can be found at .../Assassin's Creed IV Black Flag\Support\Common\PunkBuster​.

12-13-2013, 05:13 PM
Try to run the game in administrator mode and/or run the file pbsvc (Punkbuster), which can be found at .../Assassin's Creed IV Black Flag\Support\Common\PunkBuster​.

I read those suggestion in another topic as well, and I ran punkbuster right after reading it. It did allow me to play a session for about a minute, maybe 2, before getting kicked.
Still have to try to launch Uplay as admin, but haven't had time yet. I will give it a go when I get home tomorrow, really hope it works :) Thanks for the suggestions though :)

12-14-2013, 04:18 PM
Darn it, it didn't do anything :S
Get into session, walk around for 3 seconds, and I'm booted again :S

Ubisoft support is worthless as well.

I guess this really is the last Ubisoft title that I'll own legally, since they can't seem to release a single game that actually works as it should...

12-14-2013, 05:46 PM
If support suggest things that do not seem to correct the issue, please make sure to tell them that, and work with them.

I would suggest you refrain from talk of pirating any games..

12-14-2013, 06:20 PM
just checked mine isn't connecting to the ubisoft servers. it says limited mode. i played a few days back but now it isn't connecting with the servers. my internet is fine so thats not the problem.

EDIT: ok now its connected. :)