View Full Version : One possible AC4 Black Screen fix

12-08-2013, 11:14 PM
I have had all the past problems that most other ppl have experienced in regards to purchasing and ACTUALLY playing AC IV. From being unable to download the game to the game crashing and the dreaded BLACK SCREEN or infinite launch loop. After lots and lots of research I have finally SOLVED all of the issues I once had with the game and it now runs sweet in both single & multiplayer mode.

Things I tried and did not work for me:

Uninstalling & Re-installing Uplay
Uninstalling and Re-installing AC IV over & over (however my problem was related partially to this step)
Verifying files through Uplay.
Renaming DataPC_Patch.forge (allowed the game to launch but could not use or select weapons or see hints)
Unchecked sync saves with cloud (allowed me to actually play the game)
*Deleting Registry Keys. (part of the unable to download issue etc)
Updating MOBO & GPU Drivers etc. (I am not saying that updating drivers does not help, but it did not solve the problem for me.)
I also have multiple tickets with the support team, which eventually will help others overall in the long-run.

What did work for me:
I backed up DATAPC_patch.forge to a separate folder and deleted it from the main game folder. I then verified the game cache again. Once the verification process had completed successfully, it presented me with an INSTALL option. I clicked on that and it replaced the missing DATAPC_patch.forge file. No Change -- Black Screen on launch! I THEN NOTICED THAT THE SIZE OF THE GAME FILE THAT WAS INSTALLED ON MY PC WAS SMALLER THAN THE FILE BEING DOWNLOADED. For example my game would get to 100% downloaded and install at the size of 22,674MB and the actual size of the game is 22,684MB. Somewhere I was missing 10MB. Every-time I verified the game cache files it would come back successful which is what confused me. So I attempted to randomly backup and delete .forge and .map and .exe files, verify the game and then click on the install option. Uplay would then replace the files I had deleted and ONE of them was indeed the problem. FOR ME IT WAS NOT DataPC_patch.forge. Fo me It was one of the following files AC4BFSP.exe DataPC.forge DataPC_extra.forge DataPC_Intro.forge DataPC_TitleScreen.Forge. I clicked verify then install and VOILA 100% download @ 22,684MB!!! HOORAAAHH! I reluctantly pressed single player and BOOM! Game works perfect: all saves, I can use weapons, see hints. Multi player works like a charm.
I hope this info helps at least one other person.

The strange thing is that the files that were replaced through the verify/install process seemed to be the exact same size as the ones I had backed up??
And everytime I clicked verify the file verification process would come back as successful.... even though I was missing 10MB somewhere.

My PC specs are:
Win 8.1 x64 pro
GTX 560 OC (NVidia BETA driver 331.93)
4gb Ram
& I use Multiple screens which is no problem with the game and no noticable FPS drop either.

I am happy now even though this process took days and days of trial and error!!

12-11-2013, 06:18 PM
Might give a shot for this.

I wonder if the things you wrote apply for the 1.03 patch as well.

12-11-2013, 06:35 PM
Also, should I do this backup/delete process for .forge, .map and .exe located inside dlc folders and multi folders as well ? Or only the ones inside main folder which is Ubisoft/Assassin's Creed IV Black Flag ?

One final thing, the amount that I always download is 23,149MB, a little bit more than you specified. Is that normal ?

12-11-2013, 10:56 PM
Bah, didn't work for me.

Thanks tho.

12-13-2013, 03:58 PM
how do you verify the files ?

12-13-2013, 05:27 PM
how do you verify the files ?

If you open up Uplay, youll see in the top left next to the logo it will read there "games"

Once you've don't that you'll select your game from there so you'll say select Black Flag.

Now once you've done that you should see a drop down arrow on the "single player" tab. You have the option to either uninstall or verify files from there.