View Full Version : AC4 - Trophies not unlocking - Silence Fool & Business and Pleasure

12-01-2013, 09:57 PM
I've completed AC4 Story on PS4 - I've unlocked all the offline Trophies except Silence Fool Y Business and Pleasure (and By the book - still got to go back and get 100% sync on a few missions.).

I've probably earned > 500K Reales so 50K shouldn't be an issue. I've done almost all the Assassin contracts, The only two locations on my map that I haven't turned yellow are Nassau and Kingston. I've fully upgraded my ship, I've made > 300K in shipping alone. ... Not sure why the Business and Pleasure hasn't unlocked.

As for Silence Fool - I've probably killed a dozen guards while they were ringing the bell. I've done it with my hands, with stealth blades, swords, gun, ... and still no glory.

Any thoughts?

12-01-2013, 10:00 PM
They can only ring the bell once, then you kill them. That's how you get the achievement.

12-01-2013, 10:57 PM
Only > 1/2 the attempts at this they only range the bell once. Also, not explaining why the Business and Pleasure isn't unlocking.

12-01-2013, 11:38 PM
I didn't answer the Business and Pleasure issue because I don't know.

12-10-2013, 04:34 PM
I took a break from SP and went into the MP, but went back to SP last night. I decide to create a new character as I tried dozens of times to complete 'Silence Fool' (and I have also earned > 1M Reales by now in AC4 from the Companion App alone) in the hopes that the problem was with the game save and not allowing it to unlock. I did it maybe 40mins into play in the first location I could do it (Southern end of Havana) and did it on the first try. I'm certain that I was doing it right before and the game save was glitched. Now hopefully I can move through with this game save and get 50K Reales quickly and get the 'Business and Pleasure' Trophy. I've got 6 Sequence parts to go back and replay to finish 100%, and the final two trophy's in MP to get my Plat.

12-16-2013, 08:28 PM
figured id reuse this thread as opposed to making a new one. im having issues with "Silence fool". i even tried it on a new save. will not unlock. any advice? xbox one here btw.

12-16-2013, 08:55 PM
You may have to do another new save. It apparently clears (or tracks a new set) the set of data for this. I eventually got through and managed to do 'Business and Pleasure' as well with my new game save.

Also, just to make sure, you need to kill them after they've rang the bell exactly one time and use a Sword or Hidden Knives.

I got the following e-mail from Ubi several days after I had filled a bug report against it. I had already unlocked the Trophy at this point by my method, but you may want to give their method a try. If you're far along in the game, I'd suggest clearing the other trophies before going back and trying their method.

Andrea @ Ubisoft Support wrote:

Hi TAZ427,

Unfortunately we do not have the ability to force unlock the achievements/trophies on accounts.

We will be sure to report this issue to the development team for further review. However, our best recommendations at the moment are listed below:

Start by double-checking the steps on the guides listed below.
http://www.xbox360achievements.org (http://www.xbox360achievements.org/)

-Xbox platform: Restart the game if you are driven to obtain the achievement or attempt the achievement steps on a second profile

-Playstation platform: Delete the game data from the Game Data Utility which is accessible through the Playstation Main Menu - this data controls the trophy system and does not effect in-game progress or save data

Unfortunately, these are not 100% resolvable solutions. Please keep an eye on our Forums (forums.ubi.com (http://forums.ubi.com/)) for information in the future.

12-17-2013, 05:23 AM
i did start a new game, and it did not resolve the issue. maybe its a xbox one thing?

12-26-2013, 02:05 AM
Death of a Salesman - Memory Sequence 5
doesn't unlock for me.. What can I do?

All the bugs in this game really take away the fun.
Most annoying thing is when you're stuck in the environment and get either killed or spotted by enemys..

02-03-2014, 07:31 PM
I'm going to jump in on this thread as well.

100% sync on both Sequence 6 & 7 and neither trophy has unlocked. Pre Sequence 6 & Sequence 8 onwards and there isn't an issue. I've contacted Ubi support and just got the standard response "We'll look into it!"

I'm sorry Ubi, but this response isn't good enough. It's OK asking us to also contact PlayStation support, who then tell us to contact you. I'm not in the habit of being a tennis ball between Ubi & PS Support. Sort it out please. I've provided screenshots and gave an in-depth description of the problem and you still don't have a clue. I shouldn't have to start a new game just to unlock these trophies. I've paid a lot of money for this game, as have other people, across other platforms, things like this should work! Not only that it stops people from getting that platinum trophy.

What is the issue, why is this happening and what actually are Ubi doing to resolve it? You've taken my money and all I expect is an answer.