View Full Version : Can't redeem AC3 Washington Edition dlc code

12-01-2013, 07:46 PM
I know this doesn't go in here, but I couldn't post it in the right forum because it would tell me to select a thread prefix even when I did it, so I couldn't help it.
The thing is: I just pruchased a physical copy of AC3 Washington Edition for PC at a local store. I installed the game, updated it, registered the key in Uplay, and all good. But when I wanted to enter the code to unlock the dlc, it returned invalid code message. I tried entering it in-game, in Uplay, in the online store, and nothing. I looked for a solution in the support page and found this: https://support.ubi.com/en-gb/FAQ.aspx?platformid=9&brandid=22&productid=2717&faqid=kA030000000eXQnCAM So I went to the store and searched for the AC3 season pass to add it to my cart, enter the code in the checkout, and purchase it for free, as the support page says. Problem is, I can't find the season pass in the store. I found the url to the product searching in google (http://shop.ubi.com/store/ubina/en_US/pd/ThemeID.8605600/productID.258143200) but it says the product is not available. So what do I have to do? Apparently there's no other way of redeeming Washington Edition aditional content, and I can't do it the way it's supposed to, because the season pass is not in the Uplay store (which is weird, because I found it in other places like Steam, Origin, Amazon, etc, but my code won't work there either). I paid for the dlc, so I need a way to get it.

12-01-2013, 09:28 PM
Sorry but I need to keep this up.
And I forgot to say, I submitted a ticket last thursday or friday (don't remember exactly) and I haven't got a solution yet.

12-05-2013, 11:38 PM
I noticed that the AC3 season pass is available again in the uplay store, so I went there, added it to my cart and tried entering my promo code to buy it for free. Problem is, I keep getting the "invalid code" message, and the value of the season pass doesn't drop to 0.00 I made sure that I was logged into my account (which is the only one I have, by the way), and tried entering the code in both uppercase and lowercase, and nothing has worked so far. I opened a ticket in the support page too, and, besides asking me for some account details to prove ownership of my account, I haven't got an answer.

12-06-2013, 11:41 PM
Try going to the AC3 forums not Black Flag forums. You may get more help!

12-07-2013, 02:45 AM
As far as I know, this is the general Assassins Creed forum, not a specific AC IV one. In any case, I would be thankfull if you could point me in the right direction. (And like I said before, I can't post in the technical support because of the "select prefix" issue)

01-07-2014, 03:25 PM
Are they serious? I got this problem, and I see it's a really old and unresponded problem with no fix and help?

Why does all games have these unreasonable issues?

EDIT: Wait, this isn't the iddue I'm having. Sorry mate.