View Full Version : Can't kill Loreano Torres

11-23-2013, 06:14 AM
I tried to kill him six times!

11-23-2013, 09:06 AM
happend to me too it's a bug probably will be fixed in the next patch
to solve it simply jump near him and tackle him with E and then kill :)

11-25-2013, 10:02 PM
happend to me too it's a bug probably will be fixed in the next patch
to solve it simply jump near him and tackle him with E and then kill :)

this way worked for me also when I enconutered the bug

11-28-2013, 11:29 PM
Ridicilous bug that is totally unaccaptable!!! I mean, you can have a glitch in game, but this absolute bug that prevents you from proceeding an end mission is totally annoying!

E for the tackle does not even work for me!!! I tried to tackle, nothing.. tried lots of things but nothing.. Please fix this bug a.s.a.p

11-29-2013, 01:27 AM
This is why I almost like that PC versions come later. The fact that I do all side missions and collectibles before finishing the story also helps in a lot of games. Someone always have solutions to both multiplatform bugs and specific PC bugs before I get there. Stumbled across this bug earlier today, and luckily the tackle thing was already figured out by someone else.

11-29-2013, 07:32 AM
This happened to me, if he was talking when i tried to assassinate him it would not kill him, hed just stand there unable to take damage, i managed to get past it by waiting for him to stop talking, the pose of his character changes after that and he is able to be killed.

11-29-2013, 11:13 AM
Same problem here, I kill my self, then kill him as @CF_22 says, waiting him to stop talking to kill him...

12-03-2013, 09:46 PM
I've got the same problem. Has anyone solved it?

12-04-2013, 04:38 AM
This worked for me too. The first time he didn't seem to take any damage when I was beside him, some kind of round "force field" appeared over him on every shot/hit I gave, second time I was able to air assassinate him once I waited in the beam for a minute or so.

Definitely a bug, and a very annoying one at that, preventing you from going forward in the storyline.

12-20-2013, 11:54 PM
Nope. Not a bug. Took me 6 or 7 tries, but I finally got it. Climb the shifting platforms on the RIGHT side of the room. Climb on to the central platform with a sliding rail. Once it moves closer to Torres you et thecontrol option "Assassinate" (PS4). Mash it - you're done.

12-21-2013, 12:09 AM
either that or the smoke bomb works by stopping him talking then kill

12-21-2013, 01:38 AM
I didn't have this problem on PC. Only thing I had to account for was the all too common unbalanced lighting you see in so many games these days. There's no one brightness setting that works well for all parts of the game. I think I had to crank it to 7 on this part just to see the ledges that allow you to climb up.

As advanced as lighting is in games anymore, you'd think they'd have solved this problem by now.

12-21-2013, 02:04 AM
Hey we are playing assasins creed 4 for charity. Our gameplay sucks. We need help. Go to KG4K.org and laugh at our awesome failures. And you can even win prizes for donations. All money goes to childs play for childrens hospitals. Check us out and help. Kg4k.org Giving away a free collectors edition kenway statue to the highest bidder of the event. And plus you can win more items if you just donate. Kg4k.org