PDA

View Full Version : V-Sync On = 30fps - Off = Screen Tearing from Hell



VivaLaSpook
11-22-2013, 04:26 AM
I realise there's threads already for this but hopefully the more people complain the quicker it may get fixed.

Title says it all really. With V-Sync on the game is locking to 30fps - with V-Sync off it's 60fps but with horrendous screen tearing.

Turning on Triple Buffering via Nvidia Control Panel doesn't work. I have found D3DOverrider works and I am now getting 55-60fps, but we shouldn't have to use some third party software just to make the game run like it should.

i7 2600
GTX 780
8GB RAM
Latest Nvidia Drivers

drakkar321
11-22-2013, 06:42 AM
I realise there's threads already for this but hopefully the more people complain the quicker it may get fixed.

Title says it all really. With V-Sync on the game is locking to 30fps - with V-Sync off it's 60fps but with horrendous screen tearing.

Turning on Triple Buffering via Nvidia Control Panel doesn't work. I have found D3DOverrider works and I am now getting 55-60fps, but we shouldn't have to use some third party software just to make the game run like it should.

i7 2600
GTX 780
8GB RAM
Latest Nvidia Drivers

Try disabling v-sync in game and using "Adaptive V-Sync" in the Nvidia Control panel. It works very well and will completely eliminate this problem for you. You won't even need to use triple buffering.

jastonas
02-21-2014, 10:20 AM
I realise there's threads already for this but hopefully the more people complain the quicker it may get fixed.

Title says it all really. With V-Sync on the game is locking to 30fps - with V-Sync off it's 60fps but with horrendous screen tearing.

Turning on Triple Buffering via Nvidia Control Panel doesn't work. I have found D3DOverrider works and I am now getting 55-60fps, but we shouldn't have to use some third party software just to make the game run like it should.

i7 2600
GTX 780
8GB RAM
Latest Nvidia Drivers


Try disabling v-sync in game and using "Adaptive V-Sync" in the Nvidia Control panel. It works very well and will completely eliminate this problem for you. You won't even need to use triple buffering.

No need to disable vsync. Just do this 4 second fix.
http://www.youtube.com/watch?v=-ej_gyZnLhw

playlisting
02-21-2014, 01:51 PM
No need to disable vsync. Just do this 4 second fix.
http://www.youtube.com/watch?v=-ej_gyZnLhw

It works but you'll quickly tire of having to CTRL+ALT+DEL out every time you want to play the game. I use Adaptive-Vsync in the nvidia control panel with triple buffering forced on in D3DOverrider and the game works nicely for me.

I recommend reading this: http://forums.ubi.com/showthread.php/810775-Improving-Performance-Frame-Rates-in-AC4-Black-Flag-with-mid-high-Nvidia-cards

It helped improve my performance considerably. I recommend copying his nvidia control panel settings too. All my games started to look/run better after I did.