PDA

View Full Version : Vsync and 30 FPS on AC4



AherasSTRG
11-21-2013, 08:21 PM
Specs:
GTX 760
Intel i5 3570 @3.4 GHz, 3.8 GHz Turbo Mode
8 GBs of RAM

Settings:
Environment Quality: High
Shadow Quality: High
Texture: High
Volumetric Fog: On
HBAO+ (High)
FXAA
God Rays: Low
Reflections: Normal

My specs vastly excceed those of the recommended requirements. When I do not have Vsync on, I get between 45 to 62. But, when I put Vsync on, the game locks at 30 FPS and scarcely ever does it hit 60 frames per second?
Is that the game's problem or my machine's problem? What are your experiences with the game.

Solid-Snake-Eyes
11-21-2013, 08:32 PM
It's the game, it doesn't do triple buffering so if you aren't at 60 it will drop to 30. I have solved this by keeping Vsync on in the game and also running D3Doverrider in the background. With that combination I can get the full range between 30 to 60.

ProletariatPleb
11-21-2013, 08:33 PM
They removed triple buffering for no apparent reason and now it's a double buffer vsync, hence 30fps, use D3Doverrider.

AherasSTRG
11-21-2013, 10:03 PM
Where can I download D3Doverrider?

johnsilver13
11-21-2013, 11:08 PM
Turn vsync off.

i7 920 2.7GHz running at 3.7GHz
12 Gb trip channel ram
GTX 660 TI 3Gb

Running all settings at absolute max. Vsync off. 50-60 FPS in Havana.

AherasSTRG
11-21-2013, 11:39 PM
Actually D3Doverrider did wonders. Is there a catch in my using it? Like... GPU damage? System damage etc?

ProletariatPleb
11-22-2013, 03:21 AM
Actually D3Doverrider did wonders. Is there a catch in my using it? Like... GPU damage? System damage etc?
Nope.

drakkar321
11-22-2013, 07:05 AM
You can easily solve this problem by disabling v-sync in game and using "Adaptive v-sync" in the Nvidia Control panel.

Solid-Snake-Eyes
11-22-2013, 10:24 AM
You can easily solve this problem by disabling v-sync in game and using "Adaptive v-sync" in the Nvidia Control panel.
This didn't work for me, the tearing remained. D3DOverrider is the solution.

jastonas
02-21-2014, 10:22 AM
there is an easier way to fix this...

http://www.youtube.com/watch?v=-ej_gyZnLhw

playlisting
02-21-2014, 02:01 PM
The fix is simple.


Enable Adaptive-VSync in nvidia control panel
Force triple buffering in D3DOverrider


How to download and use D3DOverrider: https://www.youtube.com/watch?v=IHMmXpUiZH8

Easy program to use and very useful.

On a side note, I recommend switching from FXAA to MSAA 2x. It doesn't decrease performance at all apart from maybe 2-4 frames and it makes the game look a lot nicer in my opinion.

Hope this helped!