View Full Version : If AC4 Gives You Spinning Icon & Won't Download, Try This

11-20-2013, 06:21 AM
I have all my games and game launchers installed on a separate hard drive and when I attempted to download AC4:Black Flag it got stuck at the spinning icon after asking me where to install it and did absolutely nothing. Steps to I took to fix it:

1.) Uninstalled all games previously downloaded with UPlay (May not be necessary, I had only installed Far Cry 3 prior to this)
2.) Uninstalled UPlay and deleted the entire folder (Your folder is likely in C:\Program Files(x86)\uPlay)
3.)Reinstalled UPlay to the exact same location
4.)Launched UPlay and download for Black Flag started up

It wasn't a free space issue in my case, my drive had 10x the necessary room to hold AC4. It may not be necessary to remove your games, and you could probably back them up somewhere, but after watching that icon spin and do nothing waiting for my download I got impatient and hasty. I hope this helps someone else out who cannot get the download to start.

11-20-2013, 01:55 PM
This worked like a charm! Thank you!

11-20-2013, 02:15 PM
I did exactly what you did and it worked right away. Now it's just to wait a few hours because speeds are going from 4 mb/s to 2kbps every 10 seconds... ****ty uplay

11-29-2013, 07:02 PM
Yeah...worked also for me.
But you don't have to uninstall all other UPlay games...it perfectly worked without doing that.