View Full Version : AC 2 - Ubisoft Game Launcher

11-03-2013, 09:13 PM
I know this issue has been rehashed many many times, but I cannot get past the error: Unable to find Ubisoft Game Launcher with error code 2. I have tried everything I could find so far including:

- Uninstall/reinstall AC2
- Uninstall ubisoft game launcher, remove registry keys, delete program files(x86) ubisoft folder, then reinstall game launcher from Ubisoft site.
- Delete hosts file
- Launch uPlay, launch AC2 from there which of course launches Steam, which cannot find the game launcher.

One thing that is odd, the ubiorbitapi_r2.dll file seems to get deleted everytime I try to launch from Steam. I have to reinstall the game launcher when this happens, but it keeps happening every attempt.

I am running on windows 7 - 64 bit. I have submitted a ticket to Ubisoft, but dont expect to hear back till after the weekend.

Has anyone run into this?

11-04-2013, 07:21 AM
As you tried everything, one thing comes to mind is to check paths inside the registry keys, you can find them at following Hives:


11-04-2013, 11:28 AM
Thanks for the reply Yaz_H - I have verified that the path is correct.

11-04-2013, 08:47 PM
I have answered this in your other thread http://forums.ubi.com/showthread.php/805475-AC-2-Ubisoft-Game-Launcher-Not-Found?p=9355395&viewfull=1#post9355395

11-05-2013, 02:35 PM
One thing that is odd, the ubiorbitapi_r2.dll file seems to get deleted everytime I try to launch from Steam.

i've just noticed this, the only thing that usually delete files is your anti-virus, maybe it flagged it as a virus, sometimes it happens and it is called false/positive, try to disable it or exclude the game exe and folder from scans and detection, then launch the game and see if that solves your problem.

and disable firewall as well, dont worry you can re-enable them later , but to pin-point the problem.

P.S: run the game as admin if you havent already done that.

11-08-2013, 04:09 AM
hola me podes ayudar con el codigo del juego assassin's creed II porque me lo pide para instalar el juego aca