View Full Version : Realtone Cable Driver not installing...

10-29-2013, 04:28 PM
I have tried multiple USB ports on my computer all of them 3.0 because the two 2.0 ones are dead on my PC, i hope that doesn't affect it, when it goes to install the driver everything is successful except two parts called "hocksmit" and it says this "This device cannot start. (Code 10)"

windows 7 64 bit
16 gigs RAM
i5 3570k @ 4.1

Please help

10-29-2013, 04:36 PM
Have you read and followed this configuration guide.


Also be sure you have enough power on the USB port (should be in the above guide). Some have had to get powered USB hubs to get enough power.

Most USB 3.0 ports are backwards compatible with 2.0.

Just some other thoughts...

Is this a know working cable (maybe from a previous version of the game)?

If you have access to know working cable, try that on your system.


Try your cable on a known working system/console.

10-29-2013, 05:14 PM
ok, heres what progress ive made so far, i salvaged my old computers USB 2.0 ports and using that, the PC recognizes it as a rocksmith guitar adapter with no error messages at all, but the game itself still says that i need to plug it in

10-29-2013, 05:22 PM
i fixed it, i had to go into audio devices under microphone, then right click where it shows the adapter, raise the volume, then go to the "listen" tab and click on "listen to device" then start the game with that applied

Alfred Prufrock
10-30-2013, 02:26 AM
I had a problem getting the driver for the cable to install too on Windows 8. Turned out I had to go to the security tab and make sure that windows smart screen was letting it install.

01-14-2014, 02:22 AM
I had the same problem. For me the problem was that the drivers did not load. In Control Panel>System>Device Manager, the cable appeared as an "Other Device" with a yellow caution sign. Clicking on properties, it said that there were no driver. There was no joy in using the Update Driver function to find a driver on the web or on the computer.

But this worked.

Go into update driver in Device Manager. Click browse for the driver. Goto \windows\system32\driverstore and click search. It then will find the driver. Also the driver loads now whenever the cable is connected.

02-22-2014, 08:49 PM
Under Windows 7 (and XP) I see three different drivers being installed for the "Rocksmith USB Guitar Adapter". One is a USB composite device, one is a USB Audio Device and one is a USB Human Interface Device. The driver chosen is the USB composite device with the device type of "Unknown". I would assume that the correct driver would be the USB Audio Device. I can see no way to change which driver is chosen.

07-05-2014, 06:11 PM
My OG (short for OriGinal) rocksmith cable (not a 2014 cable) worked fine on my old windows 7 machine, but when I bought a new rig which runs windows 8 I started getting this 'hocksmit error code 10' PITA issue. So I surfed the many forums on the problem, and tried everything in various orders including:

installing and/or uninstalling asio4all
using usb 2.0 or 3.0 ports
plugging and unlpugging repeatedly
resetting the computer
installing/uninstalling drivers (there is no rocksmith specific driver you can download, btw)
turning the volume all the way up in recording devices (couldn't actually do this one since the microphone wouldn't even appear under recording devices, but I turned up the other which obviously didn't work - hey, I was desperate to play ;-)
Disabling xhci in bios (which doesn't actually exist as an option in my version of 8.1 at least - I could only enable or disable specific usb ports)
ordering a new rocksmith 2014 cable (it hasn't arrived yet so idk if it will work or not)

I also called Ubisoft customer service and walked through various steps with them.

I tried all of these things in multiple orders over the span of a couple of weeks and nothing worked. I think a lot of the fixes people have posted may have just been the last thing they did before it randomly decided to not be broken once so people prematurely posted these solutions as fixes, or maybe they had different setups, or there may be multiple valid fixes, or what have you.

One fix that kept coming up for the OG rocksmith cable was this idea that there wasn't enough power to the USB port. That sounded obviously wrong for my case because I just bought a new high end PC and the ports get something like 500(whatever the power measurement is) to each port, and the cable requires far less than that. maybe 100 or something.

Anyway, here's what actually worked despite my previous misgivings about getting enough power to the ports:

I went out and bought a powered USB 2.0 hub for about 20 bucks at best buy. Now it works. I've tested it multiple times using different ports (only usb 2.0 though - want to save the 3.0s for when I need speed), restarted my machine, and all of that actual testing that one should do before posting a fix.

I'm running windows 8.1, and using a cable from the original rocksmith, not a 2014 cable.

02-27-2017, 05:23 PM
@demitriusjp this is EXACTLY what is happening to me now, I'm going to try to mix up what ports i'm using but i'll try the powered port if this fails. Thanks a lot man!

02-27-2017, 05:44 PM
There is no driver for the realtone cable ... other than the default driver that comes with windows 10.

Asio4all will interfere with the default driver and should not be used.

Some 3.0 USB ports will need xhci or legacy modes disable/enabled in the bios .. gotta experiment here. Worst case with some 3.0 ports that just don't work is to get a powered 2.0 USB hub.

The realtone cable requires power from the USB port. Some ports don't provide enough. A powered USB hub can help here.

Other USB devices can interfere, block, or steal power, and cause the realtone cable to not install or not work.

Check your device manager. See if there is a USB device with a yellow exclamation mark when the realtone cable is plugged in. If so, your system is seeing the cable, and one of the above problems is most likely the culprit.

Unplugging and replugging can help, but also be sure to address the above problems as well.

Finally, since this is a really old thread .. that started about a different version of the game and not windows 10, I am closing this thread to avoid confusion.