PDA

View Full Version : any specific nvidia driver needed to play AC4 ?



strigoi1958
10-10-2013, 02:39 PM
I have an nvidia gtx670 and for some bizarre reason any drivers later than 314.22 only affect my ubisoft games. I had a ticket open with support for ages as I thought the new version of uplay caused my graphics and game related problems. After weeks of trouble I found someone with the same problem and was directed to the nvidia forum where I found a lot of people with driver problems after 314.22. I rolled back drivers and still had problems until a complete driver sweeper and clean install of earlier drivers fixed it.

I have tried every beta and whql (pointless piece of paper) after 314 but all cause me problems with my ubi games and not much else. In fact the drivers caused so much problems with Splinter cell blacklist I was forced to uninstall when it refused to work any more and I cannot even bear to look at it in my game library now.

I have seen some games on the nvidia site that states the specific driver needed to play a specific game..... if (like many others) I cannot use the latest drivers and ac4 needs a driver newer than 314 I'm stuck. All my other ubi games run fine on older drivers

x___Luffy___x
10-10-2013, 03:22 PM
i have a gtx660 ti and i agree the drivers after the 314.22 are not good. i have been getting some problems with them too, driver crashing or game crashing, etc. but i get these errors in mostly in non-ubi games actually.

i tried the new beta driver they released for the battlefield 4 beta and my game kept crashing or pc freezes while playing the game, so i installed the previous versions and its a lot better now.

nvidia launches new drivers for better performance of the game when a game launches and it will release drivers at AC4 launch too but these new drivers are not good, well not for my card at least. I'll just have to wait and see if it gets better for me.

strigoi1958
10-10-2013, 03:44 PM
It's not just the 600 series cards. the 400/500 and even some 700 and titans have problems. If watchdogs and AC4 need newer drivers then I cannot buy them as they will not work for me :-( I'm hoping they'll be compatible with older drivers.