PDA

View Full Version : Crash at 1st cutscene.



vegas666999
08-23-2013, 12:13 AM
SC:BL locks my PC at first cutscene. Has to be the DX 11 version causing the crash. Problem is, I can't change any settings in the games setting menu because I cant get past the first cutscene after I select the difficulty level.

I've tried changing the .ini settings as stated in the PC workarounds sticky, doesn't work.

Why, oh why, is there no settings menu BEFORE the first cutscene? Who thought that would be a good idea?

vegas666999
08-23-2013, 01:11 AM
No one has an answer?

Ok, how about this one: How do I launch the DX9 version of the game without going into the in-game settings menu?

EliteForceGames
08-23-2013, 01:17 AM
Go into your Blacklist installation folder: Blacklist\src\SYSTEM, and launch "Blacklist_game.exe"

That will launch DX9 version.

vegas666999
08-23-2013, 01:30 AM
Tried that. I believe when Uplay starts it still launches the DX11 version because I cannot get into the settings menu to switch it to DX9. The reason I believe it starts the DX11 version is because when I drag the DX11 version out onto the desktop and double click the DX9 version, a small window appears like it's launching but then disappears a split second later.

Then again I could be very wrong. In which case I cannot even play the DX9 version of this game.

I put in a support ticket a couple hours ago, but good luck with that.

vegas666999
08-23-2013, 02:11 AM
Is there a way to disable cutscenes?

vegas666999
08-23-2013, 03:37 AM
I'm at a loss. I've been very patient. I wish I could play the game I purchased.

Hilgrad
08-23-2013, 06:38 AM
I'm having this issue as well; I can't get past the first cutscene with the soldiers, it just freezes after a few seconds.

EliteForceGames
08-23-2013, 06:51 AM
I foundthis in a search, might help, hope it does
Ok I was having the same problem system validation would start then DX11 error would occur forcing the system to shut the game down, no videosettings file in the folder mentioned by others.

I navigated to the Ubisoft/Tom Clancy's splinter cell blacklist/src/system folder and dragged the file systemdetection.dll to the desktop just in case and then hit the play button in Uplay dashboard, I got a pop up message that the systemdetection file was missing and expected another crash but then the screen went black and the game started. I played a minute then exited and even checked and now the videosettings.ini file is where it's supposed to be.

Hope this helps others.

Hilgrad
08-23-2013, 06:58 AM
Wow, well, I tried that, cutscene works fine now, although I didn't get any Uplay message or the like. Ty for the help!

EliteForceGames
08-23-2013, 07:00 AM
Glad it worked!

vegas666999
08-23-2013, 07:00 AM
Go into your Documents folder, then into Ubisoft and Blacklist. Open the videoSettings.ini file with Notepad. In that file, there should be a line that says "StartupGraphicsApi=5" Change the 5 to a 4 and save the file.

This is what worked for me.

Hilgrad
08-23-2013, 07:23 AM
Hrm, well, the StartupGraphicsApi Option didn't really make a difference for me, it was more the systemdetection file. While I can now actually get past the starting point, my FPS is something really awful; originally it was set at Ultra; even when I turn it all the way down to Low, the fps still chuggs at like 10 or something. Add to this, if I attempt to change the DirectX type to DX9 instead of DX11, it'll say that it will apply on restart, but if I restart the game, it runs the DX11 version anyway, and if I go back to the options, it's set back as DX11.

Either way, I don't think it's my system; when I actually got it to run for a brief period before without removing the systemdetection file, the FPS was fine
(Running a GeForce GTX670, i5-3750K CPU with 8GB RAM, shouldn't be a problem)

EDIT: Now it runs in DirectX9, so I've solved that part, but FPS is still something awful. Feels like the game's trying to run everything on my CPU and ignoring my graphics card or something.

2nd EDIT: OK, I APPEAR to have fixed it for now. Once it was in DirectX9, put the systemdetection file back into the main folder, appears to work for now at the expected framerate.

sid_.
01-22-2014, 07:27 AM
None of them works for me. I'm finally angry about Ubisoft again. After hours downloading, installing and patching infinite time (which still do every single time I run the game) I can't even pass the first f***ing cutscene!
Jesus Christ, this game is on the market months away, not fixing this is just stupid and show no consideration for costumers.
I'm giving up and ask my money back and I suggest other do the same.

Ubi-MoshiMoshi
01-22-2014, 12:55 PM
Hi and welcome to the forums, please open a ticket with Technical Support https://support.ubi.com