View Full Version : Assassin's Creed Revelations problem. Please Help!

08-22-2013, 12:26 AM
I'm playing AC Revelations on the PC and am currently in Sequence 1 memory 5, but when I try and climb the wall to get to Captain Leandros I don't get a prompt to free run and Ezio doesn't try to climb the wall on his own. I've tried climbing up different parts of the wall, to no avail. I've restarted the memory completely and that hasn't changed anything. I've looked online for walkthroughs (text and video) and haven't found anything useful. There are hardly any walkthroughs for the PC on YouTube, the ones on PS3 and Xbox just show the character climbing the wall almost automatically. This is really aggravating me, but maybe I am missing something, so hopefully someone can help!

08-24-2013, 02:59 PM

Around 4:40. There should be a white marker indicating the only scalable part of the tower.
The PC controls for freerunning should be wasd, space bar, and right mouse button.

08-28-2013, 08:53 PM
I see the white marker, and as i run through it and to the wall nothing happens. I will try using right mouse button though.

09-05-2013, 04:35 AM
how do i get to maps and books you bough from a book store

09-05-2013, 04:40 AM
some one please help me
how do i get to maps and books you bough from a book store

09-11-2013, 01:42 AM
I believe the maps only unlock the treasure icons on the main map (select for ps3, back button for 360), you can't actually pull them out to view. You can't read the books in the game either (except for 3 short excerpts in the Galata HQ). But you can always read the books in real life. :P

09-11-2013, 01:47 AM
you should just reload i had that problem and when i when to the check point before that it worked the next time i did it so i would suggest aborting mission and reloading the mission to the beginning

please tell me if it works if not i will find a different way for pc