PDA

View Full Version : Crashing at Startup: SOLVED



Angelw1ng
05-26-2013, 11:10 PM
If you, like me, have been unable to get this game running (i.e.: you open the game with uPlay, hit "Play," see the Blood Dragon splash screen, and then the game crashes), I figured out what's happening:

The game is trying to launch the DX11 version of the application, which is broken.

Here's how to fix it. The two versions of the application are located here:

C:\Program Files (x86)\Steam\steamapps\common\Far Cry 3 Blood Dragon\bin

One is called "fc3_blooddragon_d3d11," and one is simply called "fc3_blooddragon."

Unfortunately, once the game gets it in its head that it should launch the DX11 app, there's nothing normal (i.e.: editing a .CFG somewhere) that you can do to fix it. So you have to trick uPlay:

1. Yank both .exe files out of the folder above for safekeeping.
2. Copy the DX9 version of the game back into the folder. Add "_d3d11" to the name.
3. Launch the game and switch from DX11 to DX9 in the game settings.
4. Quit the game, delete your modified application, and move the original .exes back.

Enjoy!

EvilPixieGrrr
05-28-2013, 08:40 PM
Thanks for sharing this info!

MarioTommadich
09-20-2013, 01:41 PM
This "info" does not work. Don't waste your time folks.

n0merzi
12-19-2016, 09:12 PM
If you, like me, have been unable to get this game running (i.e.: you open the game with uPlay, hit "Play," see the Blood Dragon splash screen, and then the game crashes), I figured out what's happening:

The game is trying to launch the DX11 version of the application, which is broken.

Here's how to fix it. The two versions of the application are located here:

C:\Program Files (x86)\Steam\steamapps\common\Far Cry 3 Blood Dragon\bin

One is called "fc3_blooddragon_d3d11," and one is simply called "fc3_blooddragon."

Unfortunately, once the game gets it in its head that it should launch the DX11 app, there's nothing normal (i.e.: editing a .CFG somewhere) that you can do to fix it. So you have to trick uPlay:

1. Yank both .exe files out of the folder above for safekeeping.
2. Copy the DX9 version of the game back into the folder. Add "_d3d11" to the name.
3. Launch the game and switch from DX11 to DX9 in the game settings.
4. Quit the game, delete your modified application, and move the original .exes back.

Enjoy!

Did not work for me.

Just an answer for the folks like me who searched for hours and could not get the game to even startup:
Windows 8.1
i7 4700MQ
NVidea GT 755M
Game installed on external hard drive with > 2TB capacity
Last point seems to be a problem for the game. I don't know how and why this crashes the game at startup, but installing the game on my local drive (secondary partition) with a capacity of about 128GB solved the problem!!!

I read about this hint only once at a random forum and it worked for me!

xrihardx
12-30-2016, 09:57 PM
If you, like me, have been unable to get this game running (i.e.: you open the game with uPlay, hit "Play," see the Blood Dragon splash screen, and then the game crashes), I figured out what's happening:

The game is trying to launch the DX11 version of the application, which is broken.

Here's how to fix it. The two versions of the application are located here:

C:\Program Files (x86)\Steam\steamapps\common\Far Cry 3 Blood Dragon\bin

One is called "fc3_blooddragon_d3d11," and one is simply called "fc3_blooddragon."

Unfortunately, once the game gets it in its head that it should launch the DX11 app, there's nothing normal (i.e.: editing a .CFG somewhere) that you can do to fix it. So you have to trick uPlay:

1. Yank both .exe files out of the folder above for safekeeping.
2. Copy the DX9 version of the game back into the folder. Add "_d3d11" to the name.
3. Launch the game and switch from DX11 to DX9 in the game settings.
4. Quit the game, delete your modified application, and move the original .exes back.

Enjoy!

Still doesnt work, when i start the game it gets stuck on the screen where it says tracking. I srsly want to play this!