PDA

View Full Version : PC save game issue



Xantac
05-17-2013, 03:47 AM
I've read about this happening to others but haven't seen any workarounds for this. So I have re installed my OS and also AC3 but when I tried to load the save file I get this message or something similar "load failed required downloadable content missing" .

Anykeyer
05-17-2013, 06:01 AM
Install DLCs then

Xantac
05-17-2013, 07:29 AM
Install DLCs then

Yea that and patching it up was the first thing I did.

Anykeyer
05-18-2013, 07:40 AM
Most likely you forgot something. Like Benedict Arnold or brazilian language DLC.

Xantac
05-18-2013, 01:07 PM
Well it looks like I don't have the DLC installed. I can only access the dlc through my e-mails and they send me to a link that says
"Sorry,

It is too late to download this file. You were allowed to download within 30 days.

If you have any questions, please contact Digital River Customer Service at CustomerServices@digitalriver.com."

So I tried using my season pass key in game "already redeemed" I have all three Washington packs though.

Can't even find the ones you have mentioned to download anywhere.


I purchased through u-play or the "abstergo store"

Anykeyer
05-18-2013, 04:17 PM
Contact Ubi support. They may give you new links. Also remember to backup DLC installer files because of this stupid time limit.

UbiVolfbane
05-21-2013, 01:42 AM
Xanaxman, please check your email and attempt to re-download the content. You should have received extend downloads. If you are unable to download the content, please include your order number for the orders you wish to have extended. Once received, the replacement team will be able to extend and increase your download attempts.