View Full Version : AC III Problems

05-07-2013, 01:07 PM
Hello all,

So I've recently purchased this game and I got a major issues already.
My problem: Hugh lag.
When I was on the boat My FPS: 51 - 61.
When we arrived in Boston FPS: 8 - 25
It jumps from 23 to 16 to 8, lowest was 4fps in boston.
And I can run Crysis 3 at 50 fps Ultra-settings, what does this mean?

GPU: nVidia GTX 650 GDDR5 - 1GB
CPU: AMD Phenom II X4 965 Black Edition - 3.40Ghz
RAM: Corsair 4GB - 1333Mhz
OS: Windows 7 Ultimate - 64Bit.

How come I can play newer games at max settings without lag but this epic game not?

P.s: VSync won't help, tried it.

05-07-2013, 02:09 PM
No one on this forum can help you, unfortunately, it's an optimization problem that will never be solved :(

05-07-2013, 11:33 PM
As Bolz says (bolz? well, that sounds strange)... Anyway, as Bolz says, there is nothing you can do really. The game is horribly optimized, having serious optimisation issues. In fact, it is one of the worst optimized games out there. What I would suggest is:
1. Do not purchase ANY downloadable content. Uninstall the game. Reinstall it, but do not install ANY updates. Check your FPS again.
2. If the problem persists, install ONLY the first update (1.01)
3. If the problem persists, try playing on a computer with an Intel CPU, even if it is not as powerful as the AMD one you are stating above
4. If you have arrived here, better contact support. Wait for 3 weeks and see what they tell you
5. If none of the above helps, I do not know what else could work. You could as well return the game.
Post your problem here also, please, it's a thread dedicated to the low FPS most of us are getting in the PC version of AC3: http://forums.ubi.com/showthread.php/737072-AC3-Low-FPS/page105

05-07-2013, 11:57 PM
Try turning off Vsync. That is the only thing known to work, at least to a point. In single player, Vsync cannot be turned off from within the game, so you have to edit the ini file. It should be in

c:\Users\YourWindowsUsername\AppData\Roaming\Ubiso ft\Assassin's Creed\

the name of the file is Assassin.ini, just change the line VSynch=1 to VSynch=0.

05-25-2013, 02:36 AM
I finished the story line and I thought I did all the homestead missions. However, I still don't have access to crafting materials like gold ore and iron ore. What did I miss?