PDA

View Full Version : help please!! my games isnt working ) = its such a good game please some help



gggggreg
02-26-2013, 03:38 AM
i have recentally puchased an alienware - it amazing - 3.4ghz - 10gb ram - super fast - 1920x1280 - and i also puchased assassins creed 3, But when i run it at its lowest settings (still on 1920x1280, but that shouldnt really matter) but everything normal my game only works at 26fps - 10fps!!! and when on ULTRA SETTINGS MY GAME RUNES AT 2 TOO 4 FPS!!!!!!!!!!! its stupidly low and unplayable!! please someone help if anyone can do anything i would be very gratefull! i have looked on internet for days and have found out that some old drivers fo navida work better than new ones , but im on amd and dont want to break or change to much of my laptops stuff, someone please help or tell me if there is a patch comeing out for this! it would be very help ful!! thanks. greg

specs- i7 3630 3.4ghz
ram 10gb ddr 16000
windows 7-
amd 7970 2gb graphics card,

please email me if anyone one has any idea how to fix this a [email removed] thankyou very much

Mr_Shade
02-26-2013, 12:11 PM
Hi There,


I take it you have a Laptop? - Laptop cards are not supported by the game - so while they may work, there are differences in performance and drivers, which may stop the game from working correctly.

I fully understand that gaming laptops can perform well on certain games, the graphics card in them is not always a direct comparison to the desktop version, so performance can suffer, so you have to accept lower details etc.

I would suggest making sure your drivers are upto date - www.amd.com (http://www.amd.com) - I would suggest against trying to install any nvidia fixes / drivers.

If you still have issues, please contact support:

www.support.ubi.com (http://www.support.ubi.com)

stormbringer.tx
11-25-2013, 11:40 PM
This was driving me crazy too. I ended up disabling the Alienware Control Console software and it ran fine. I remembered that I used to have problems with some games and Stardock Windowblinds. I'd have to disable it first to get the games to work. I've got a new AW 14 laptop and tried uninstalling the NVidia drivers and installing the latest and it still wouldn't work. As soon as I disabled AW Control Center the AC BF launched with no problem.