PDA

View Full Version : Ubisoft-server unavailable, please try again later.. AC3 PC



Olarunds88
02-05-2013, 08:49 PM
Hi!
I got hang of AC3 for PC on saturday and ever since tried to redeem my DLC's and extra content from the game. However, every time ive pressed extras and redeem code all i get is a message saying that the ubisoft-server is unavailable, please try again later.

Ive let uplay thru the firewall as well as ac3... and still nothing:(
Does anyone have any tips?

regards

Olanrunds88

YazX_
02-06-2013, 12:03 AM
disable firewall completely and try again, if its no use, contact your ISP and see if they are blocking ports on your connection.

Anykeyer
02-06-2013, 06:16 AM
This occurs when you enter incorrect cdkey (for example you're trying to redeem regular retail cdkey that does not have any DLC unlocks) in SP extras menu. Try entering your keys in multiplayer because it usually gives correct error description instead of disconnecting from Uplay.

Olarunds88
02-06-2013, 11:44 AM
The game shows in my Uplay account, but not on the uplay website. I can play it and all good.

Olarunds88
02-06-2013, 11:45 AM
And i cant enter anything anywhere because when i press Extras or News in the game i only get a Server not available at the moment.

Olarunds88
02-06-2013, 05:03 PM
This occurs when you enter incorrect cdkey (for example you're trying to redeem regular retail cdkey that does not have any DLC unlocks) in SP extras menu. Try entering your keys in multiplayer because it usually gives correct error description instead of disconnecting from Uplay.


To update you: Ive tried via Mulitplayer, but i cant get thru there either. I get the same message, Ubisoft-server not available..

matic1222
02-06-2013, 06:26 PM
To update you: Ive tried via Mulitplayer, but i cant get thru there either. I get the same message, Ubisoft-server not available..

Same here, ports are open, firewall is down too, but no connection to any online features. Still talking to support, I hope this will be fixed soon.

Ubi-MoshiMoshi
02-07-2013, 11:27 AM
Hi guys, if you have opened all the ports http://support.ubi.com/en-US/answer_detail.aspx?lang=en-US&key=us&platformid=88&productid=2511&answerid=17490 and this error still appears then please do open a ticket with Technical Support, it may be also that your ISP is blocking certain ports which are needed.