View Full Version : Can't make screenshots in Assassin's Creed 3

01-31-2013, 07:10 PM
Hello all,

I've tried pretty much everything to able to make some screenshots while playing assassin's creed 3. Some cool scenery shots and stuff. But for some reason I just CAN'T make a freaking screenshot. What the F! I've tried everything, starting Uplay and assassin's creed 3 as administrator, removing any limitations, i tried print screen, F10-12 (cause sometimes that works), but really nothing works! How can I make a screenshot!?



01-31-2013, 08:12 PM
fraps or msi afterburner

02-01-2013, 12:45 AM
If you have Steam, launch the game through that and you can use F12 to take screenshots.

05-10-2013, 12:35 PM
Can I record in AC3 using steam too?

05-10-2013, 01:46 PM
No, for recording, I use MSI Afterburner (don't need to have a MSI card to use it :)), works well, low performance hit, though a later re-encoding is advised because of the file sizes. Another contender is PlayClaw, I haven't used it, but from what I hear, using it also causes a very low performance hit.